Dell inspiron 3520's display neither working nor booting

Yash hira

Estimable
Feb 27, 2015
18
0
4,570
2
Hey friends, My dell laptop's display is not working. Whenever i press the powerbutton only 1power led light come's and it is stable. I also checked my fan it is working well. I have detached the battery for some time to resolve the issue but nothing happens. After inserting my battery i power on my laptop and hear 4 beep code. I again detach the battery for more than 25 mins but this time laptop boots up and i have also reinstalled my windows 7 and used my laptop for 4 hours. Again on next morning same problem happen again display isnot working. I have also tried to check by using hdmi cable to my led but nothing happened. I have used to watch movies on led with the same hdmi cable and it new one. One important when i reinstalled windows 7 my laptop is running fine but after some time i have encountered with blue screen and my computer freezes and and i foced shutdown it.

LAPTOP CONFIG-
DELL INSPIRON 3520
RAM -4 GB
OS-WINDOWS 7 64 BIT
HDD-TOSHIBA 500 GB
 

hang-the-9

Titan
Moderator


If you are installing Windows again you need to do a backup first if you like your files. If you don't have backups of the files you need, get another hard drive and install Windows on that. Did you ask what the tech did to the BIOS? Seems odd that they wold fix something but break something else and not fix that. Is the drive mode changed to Legacy from AHCI or vice versa?
 

Yash hira

Estimable
Feb 27, 2015
18
0
4,570
2
Thanks hang-the-9 ,i have tried removing the ram from my laptop cleaned it and insert it with no success.i don"t think so that motherboard is dead because my laptop fan still runs and i can hear hdd sound. Last time my laptop was working correctly but unfortunated i got a bsod about driver Irql less or equal and some driver error after getting 3 bsod my laptop stopped showing the display.
 

Yash hira

Estimable
Feb 27, 2015
18
0
4,570
2
Hello guys my problem is now solved i take my latop to a technician and he checked with another charger ,the problem is that my charger doesnot charge my laptop's battery. But i have now one problem technician made some changes in my bios setting and my bios is now accept my pendrive in uefi mode and when i used to install windows i got an error windows cannot be installed to this disk because this is a mbr disk etc.pleaee tell me what to do?
 

hang-the-9

Titan
Moderator


If you are installing Windows again you need to do a backup first if you like your files. If you don't have backups of the files you need, get another hard drive and install Windows on that. Did you ask what the tech did to the BIOS? Seems odd that they wold fix something but break something else and not fix that. Is the drive mode changed to Legacy from AHCI or vice versa?
 

Yash hira

Estimable
Feb 27, 2015
18
0
4,570
2
Hey i think that i should try resetting my bios setting to default. I didnot ask technician ,i wil ask him tomorrow and post the solution. THANKS FOR TAKING INTEREST
 
Thread starter Similar threads Forum Replies Date
Aizazm Laptop Tech Support 3
C Laptop Tech Support 2
R Laptop Tech Support 4
S Laptop Tech Support 1
T Laptop Tech Support 1
K Laptop Tech Support 0
hikswolf Laptop Tech Support 0
Hacknique Laptop Tech Support 9
R Laptop Tech Support 1
H Laptop Tech Support 1
T Laptop Tech Support 3
N Laptop Tech Support 1
bhaaratsharma Laptop Tech Support 1
TommyInfinity Laptop Tech Support 10
Cynub93 Laptop Tech Support 1
merksu81 Laptop Tech Support 3
Jehosaphet1 Laptop Tech Support 6
D Laptop Tech Support 1
Ay111Z Laptop Tech Support 1
R Laptop Tech Support 5

ASK THE COMMUNITY