DroidX2 and USB Port Help


Aug 9, 2010
Hey Gang,
I've got a non-rooted DroidX2 and I'm learning my way around. I added some free apps and personal photos to my SD card and when I went to plug in today, I got an error message that asked me to use USB a 2.0 port on my PC rather than a 1.0 or 1.1
All my ports on my HP G60-243CL Lappie are 2.0. It also randomly goes into this "found device" loop where it keeps making the dongle sound and throwing up muultiple copies of my SD card and the internal memory of the phone which forces me to close all these windows so I can "safely remove device". To saver you the obvious, I don't have any yellow exclamations in "device manager" and I tried uninstalling the USB Host Controllers from Device Manager, but I didn't uninstall every single "USB Root Hub" one by one. It's not the phone as my wife's phone acting the same on it and it's not the usb cable, I had 4 to choose from. Very unlikely a physical issue with the PC also, it's got low miles and it worked perfectly 2 days ago. I assume it's either a mobile phone virus or some setting for the USB configuration is out of whack.
Thanks much in advance.


If this is happening on all of the ports, try to reset the BIOS, check with HP for the procedure. May need to open the case and pull the battery. You can try to just reset the BIOS to defaults, but that probably won't work. Could try a BIOS update.