DVD Drive not working (not recognised)

mitsos1os

Distinguished
Jul 18, 2009
6
0
18,510
0
Hi, I have a Packard Bell Easynote SJ51. It comes with the dvd drive Mashita UJ-870. One day the DVD stopped working. It wasn't even recognised in Bios. On the CD ROM entry in the bios it was None, and i couldn't change it. Although the Bios doesn't detect the device it is detected in device manager in Windows but with an error code 10. I have tried all the scenarios about uninstalling iTunes or recording software (neither was installed), deleting upper and lower filters in registry (neither was there) but nothing. One hint is that the drive's name in device manager isn't correct. It has some random characters like @$#$%... This usually happens (on desktop pcs) if on an IDE channel you mess up the master and slave devices. But here there isn't such a thing. Only one device on Ata, two Sata disks, and no configuration option either. Also,it happened all of a sudden so no option was changed. Finally I can assure you that it isn't the drives fault, because I tried it on an other computer, and it worked perfectly, with also the correct name recognised.
 

mitsos1os

Distinguished
Jul 18, 2009
6
0
18,510
0
UPDATE: I found that If I have a bootable cd rom in the drive, and then keep the drive spinning, the drive is detected in the bios boot menu...????? What could this mean?
 

mitsos1os

Distinguished
Jul 18, 2009
6
0
18,510
0
UPDATE: I Solved it! In device manager in windows when I browsed the IDE/ATA Channels I saw two devices connected with Ultra DMA Mode 6 transfer modes, and one device with multi Word DMA. So i guessed, these were my 2 disk drives (DMA 6) and the dvd drive (multi word). So I figured out that there has something to be as to how the dvd is recognised in master or slave settings. Unfortunately the bios doesn't offer such settings. At post, there is an option to press F3 for disc tray open. I tried that and found out that if I open the tray this way, and immediately enter bios the DVD was recognised successfully! So after that I logged into Windows and saw that the third device (the dvd) was now with an Ultra DMA mode 2 transfer mode, and the name appeared correctly and the DVD worked just fine. I then saved the bios settings and turned off the computer.
Even turned it on again and rebooted a couple of times just to be sure.
 
Thread starter Similar threads Forum Replies Date
W Laptop General Discussion 1
K Laptop General Discussion 1
P Laptop General Discussion 2
S Laptop General Discussion 1
A Laptop General Discussion 1
F Laptop General Discussion 2
F Laptop General Discussion 1
S Laptop General Discussion 5
S Laptop General Discussion 4
L Laptop General Discussion 1
J Laptop General Discussion 3
S Laptop General Discussion 5
U Laptop General Discussion 3
N Laptop General Discussion 6
B Laptop General Discussion 3
A Laptop General Discussion 1
J Laptop General Discussion 1
C Laptop General Discussion 1
fxv300 Laptop General Discussion 6
cha11enger Laptop General Discussion 5

ASK THE COMMUNITY