Solved! fixing amplifier channel left/right not working

Oct 14, 2018
1
0
10
0
My sony dhc-mini MD 77amplifier channel not working, right isn't giving good sounds, it's being distorted and if I change the speakers or swap their connection it's still the same thing... I've searched virtually everywhere on Google and watched practically every video I can but none shows me my system, therefore I still can't fix it...
Please any help?
 
It might well need to have the controls cleaned. If you can get inside you might find a blown fuse. In some amps there are two fuses per channel and if one of the pair blows it will produce distorted sound. If they both blow it produces no sound.
A tech could repair it but at what price?
Fortunately each part of that system is separate and can be used with a different integrated amp so you can just replace that.
 

kanewolf

Splendid
Moderator
The most basic possiblity is the volume or balance controls are dirty/corroded. They could cleaned with contact cleaner. You could have one or more cracked solder joints. You could have bad internal components. Nobody on a message board will have a fix. It requires hands-on with the unit.
 
It might well need to have the controls cleaned. If you can get inside you might find a blown fuse. In some amps there are two fuses per channel and if one of the pair blows it will produce distorted sound. If they both blow it produces no sound.
A tech could repair it but at what price?
Fortunately each part of that system is separate and can be used with a different integrated amp so you can just replace that.
 
Thread starter Similar threads Forum Replies Date
L Audio 0
M Audio 0
D Audio 2
C Audio 0
H Audio 7
F Audio 1
S Audio 4
J Audio 3
C Audio 1
G Audio 1
T Audio 1
L Audio 1
E Audio 1
R Audio 1
D Audio 2
B Audio 1
A Audio 2
G Audio 1
P Audio 2
M Audio 1

ASK THE COMMUNITY