Frame Rate drop on Asus GL753VE

Farwil

Prominent
Jul 20, 2017
5
0
520
1
Hello everyone,

I've recently bought an Asus Rog GL753VE-GC004T and I'm trying to play a quite old game, Dungeons and Dragons online. Here are the spec of my computer

i7-7700HQ, 2.8 GHz,
SSD 128 GB
HDD 1024 GB,
16 GB RAM,
nVidia Geforce GTX 1050Ti


However, my fps, standing still and doing nothing, range from 50 to 160. When I cast a spell, it drops to 10 for one second.

I have only bought the laptop two weeks ago. The temperature of both GCP and CPU are 40-50°, using Rog gaming center app that helps me with valves.


https://rog.asus.com/forum/showthread.php?90966-GL753VE-Poor-performance

I tried this as well but didn't help much. Any suggestion? It also seems like my FPS vary whether my laptop is in charge or not, no idea if it's normal.

Thanks in advance.
 

Farwil

Prominent
Jul 20, 2017
5
0
520
1
Found the issue. It was caused by the Asus ROG Gaming Center App having the fans to 70-80% (which I set manually everytime I play to not overheat my CPU/GPU). Having the fans only up to 30-40% makes my game run steady and smooth.
 

Farwil

Prominent
Jul 20, 2017
5
0
520
1
Hi velo,

I'm not tech savvy, so I'm not entirely sure how to check. Sorry I should have mentioned that. It's my first time with a laptop.

In my battery settings, I have these options:

Activate Energy Saving when battery is below X threshold.
Reduce Luminosity when Energy Saving is active

During movies or videos with battery power:

- Optimize for battery lenght (the chosen one)
- Optimize for video quality

EDIT: I just googled online, it's on "Balanced". Should I change it to High Performance?

EDIT: I just gave it a try and the FPS is at a steady 60 in even in Ultra high. Some fps drops in Fraps but that's because I just need to use OBS instead. Thank you very much, it seems to have solved my issue!

EDIT 3: Seems like it comes and goes. Still had the fps drops tonight while playing, and it caps at 32 fps again even at very low, althou nothing changed.
 

Farwil

Prominent
Jul 20, 2017
5
0
520
1
Yes, everything up to date. I mainly play that game or black desert online, which weirdly, even if it's a really heavy game, seems to run smoother in low settings.

Right now, my FPS cap at 32 for some reason, and not really experiencing a lot of drops because I changed the video card settings (the one described in the first link in the OP) and then changing the High performance battery mode, but it's still weird my FPS cap at 32 max in DDO, I think.
 

Farwil

Prominent
Jul 20, 2017
5
0
520
1
I did try that. It works okay, but for some reason the game caps at 30 FPS now. I believe the game should be much more fluid seeing how dated the game is and how good my laptop is compared to it.

These are the settings in game:







Even without Sync Refresh Rate, everything Very Low, I get unstable FPS and weird drops.

Question: is it normal for a game to take my GPU memory completely? The Asus Rog gaming center shows the Memory from GPU in red when I have a game in full screen.
 

Farwil

Prominent
Jul 20, 2017
5
0
520
1
Found the issue. It was caused by the Asus ROG Gaming Center App having the fans to 70-80% (which I set manually everytime I play to not overheat my CPU/GPU). Having the fans only up to 30-40% makes my game run steady and smooth.
 
Thread starter Similar threads Forum Replies Date
T Laptop Tech Support 0
WaZzif Laptop Tech Support 0
T Laptop Tech Support 0
fallingtv Laptop Tech Support 0
ZahidRidwan Laptop Tech Support 3
qwpMrMarius Laptop Tech Support 0
J Laptop Tech Support 2
G Laptop Tech Support 1
Xxmlgxx Laptop Tech Support 1
B Laptop Tech Support 1
S Laptop Tech Support 2
L Laptop Tech Support 1
H Laptop Tech Support 6
L Laptop Tech Support 5
F Laptop Tech Support 7
L Laptop Tech Support 1
F Laptop Tech Support 1
H Laptop Tech Support 1
D Laptop Tech Support 1
K Laptop Tech Support 2

ASK THE COMMUNITY