GTX 765M "not connected to the computer" on my Alienware laptop!!

ArmaanS190

Commendable
May 5, 2016
2
0
1,510
0
I have an Alienware 14 laptop for a few years now. Recently, I noticed that most of my games started to lag very oddly. I first checked on NVIDIA GeForce Experience to check if the games were 'Optimised', and it said that it could not find any drivers for my PC. Then I checked for the nVidia Control Panel and it wasn't there. After a little bit of searching, I checked for 'hidden devices' in the device manager, and my NVIDIA GeForce GTX 765M was there, but it was greyed out. I went to its properties and it said
"Currently, this hardware device is not connected to the computer. (Code 45)
To fix this problem, reconnect this hardware device to the computer."

I don't know what to do! Please help!!
I am on WIndows 8.1 with i7.
 

ArmaanS190

Commendable
May 5, 2016
2
0
1,510
0


The GeForce Experience had updated drivers a week or so back, but it was running pretty smoothly since then.

Edit: I have not tried updating the BIOS because I am not sure what to do :(
 
Thread starter Similar threads Forum Replies Date
L Laptop Tech Support 0
T Laptop Tech Support 6
D Laptop Tech Support 0
C Laptop Tech Support 1
F Laptop Tech Support 3
F Laptop Tech Support 1
K Laptop Tech Support 1
D Laptop Tech Support 1
A Laptop Tech Support 1
P Laptop Tech Support 1
B Laptop Tech Support 2
I Laptop Tech Support 1
B Laptop Tech Support 2
J Laptop Tech Support 1
A Laptop Tech Support 1
M Laptop Tech Support 1
L Laptop Tech Support 1
G Laptop Tech Support 1
G Laptop Tech Support 0
P Laptop Tech Support 1

ASK THE COMMUNITY