Hello everyone, im hoping someone here can help me. Ive just purchased an asus f555 laptop. I was just browsing the internet w

rodluis69

Commendable
Mar 23, 2016
1
0
1,510
0
Hi, i just bought an Asus f555 laptop on monday of this week. I was browsing the internet today when my laptop froze, restarted, and then entered a god awful bios loop. Please help
 
Hi,

Here are some troubleshooting steps that may help.
- First is to do a hard reboot, remove the battery and unplug the AC adapter then press and hold the power button for 20 seconds then try booting it up again.
- If it will just get stuck on the BIOS loop do reseat the RAM's, remove them all for couple of seconds then put them back in making sure everything is seated properly.
- Next to try if this will still not work is to load into BIOS and press F9 to reset BIOS to default.
- If it will still get stuck on the same loop, remove the HDD off the laptop then boot it up and see if it will go into a loop.
- If the laptop will boot to a black screen with an error message about a Boot disc missing that means it's the HDD that is faulty.
- But if the laptop will still get stuck on the BIOS loop that means it's the motherboard that is faulty.
- Do contact ASUS for a repair since it's still under the factory warranty.
 

Similar threads


TRENDING THREADS