Help! Catalyst Control Center not working After Windows 8.1 Update

pixelknight12

Estimable
Dec 2, 2014
1
0
4,510
0
Alright so:

I have a laptop with an AMD radeon HD 8670m gpu and i3 cpu.
Ive been playing league of legends for almost 2 years now with no problems until today.

My laptop automatically restarted to update to windows 8.1 and c.c.c. stopped working. Without it, my computer runs league with the intel 4000 driver i presume, and so i have 5 fps.
When i right click the desktop, there is only one c.c.c. option to open it. Before updating to win 8.1, there were two. Then, when i click to open it, it does not open for some reason and i get this error:
http://img21.imageshack.us/img21/811/fdc3.png

I've also tried to download previous driver packages from the amd site. Tried 14.4 and c.c.c. ins installed normally, but then when i open league the screen flickers like this!: https://www.youtube.com/watch?v=w_FJqDCm4ow
So i went to device manager, right clicked the graphic card and updated it. Back to 0.
Even though in device manager it says i have the latest driver version, when i went to the amd site and download the "amddriverdownloader.exe" , it said its not up to date and the latest version is 14.9 so i updated to it, and the screen flickers and when i right click, only one option to open c.c.c. and i get the same error. (http://img21.imageshack.us/img21/811/fdc3.png)

Help please!



 

Remixex

Estimable
Mar 18, 2014
46
0
4,610
7
Weird, but i'll put my money on software problem, i want to see what drivers is your computer using to do the stuff it's asked to do, first i want you to check that in the BIOS, i wanna know if your PC is actually using the 8670 GPU and not the Intel one, since BIOS are all different you'll have to navigate through the options until you see main graphic adapter or something, PCI or something of that nature, if your PC BIOS is actually detecting and using the GPU answer back because i have more stuff i want you to try
Best of luck i'll be following this thread
 

Remixex

Estimable
Mar 18, 2014
46
0
4,610
7
Weird, but i'll put my money on software problem, i want to see what drivers is your computer using to do the stuff it's asked to do, first i want you to check that in the BIOS, i wanna know if your PC is actually using the 8670 GPU and not the Intel one, since BIOS are all different you'll have to navigate through the options until you see main graphic adapter or something, PCI or something of that nature, if your PC BIOS is actually detecting and using the GPU answer back because i have more stuff i want you to try
Best of luck i'll be following this thread
 

DougLYX

Distinguished
Apr 9, 2011
8
0
18,520
1
check your system for fragments and defects on the boot drive while in windows prior to loading any apps/games, run a system cleaning app afterwards if that will help, then go check for latest utils on amd/ati website for your video...there is some tweaks out there for linking onboard video with the extra gpu/apu u have installed. also make sure u update all the default drivers for the system..then the gpu/apu drivers...then attempt the tweak utils. this should improve video a bit. purging system's temp and other areas of crap u don't even use kinda helps a bit too, ccleaner works wonders on crap cleaning, also theres a freeware razer game booster that might help also to put other system stuff to sleep while allowing ur game to get best performance possible on that laptop.
 
Thread starter Similar threads Forum Replies Date
T Laptop Tech Support 9
A Laptop Tech Support 1
R Laptop Tech Support 1
Z Laptop Tech Support 2
A Laptop Tech Support 5
V Laptop Tech Support 1
H Laptop Tech Support 4
H Laptop Tech Support 11
M Laptop Tech Support 1
W Laptop Tech Support 2
S Laptop Tech Support 3
T Laptop Tech Support 2
G Laptop Tech Support 1
ItZzSora Laptop Tech Support 2
J Laptop Tech Support 13
Y Laptop Tech Support 5
N Laptop Tech Support 3
A Laptop Tech Support 1
I Laptop Tech Support 2
J Laptop Tech Support 1

ASK THE COMMUNITY