Hitachi TV won't turn on.

Jul 6, 2018
15
0
70
4
So, my TV won't turn on. It is a Hitachi 42". I have tired unplugging and replugging it. It does work sometimes but it eventually goes back to this state. When I plug it it the screen blinks with just gray and goes back to dead. When it is normal there is a red light indicator that is on when it is off and it is not on. I've taken it apart and have not found anything wrong with the PSU. What happened?
 

jimmysmitty

Distinguished
Moderator
Oct 5, 2007
551
0
19,010
42
Sounds like a possible capacitor issue. Had a Samsung that would work once in a while and if we got it on it would stay on but when off would take forever to get back on. Turned out a faulty capacitor caused this issue.
 

jimmysmitty

Distinguished
Moderator
Oct 5, 2007
551
0
19,010
42
Sounds like a possible capacitor issue. Had a Samsung that would work once in a while and if we got it on it would stay on but when off would take forever to get back on. Turned out a faulty capacitor caused this issue.
 
Jul 6, 2018
15
0
70
4


Yeah, that's what I thought it was but I opened it up and all the capacitors looked fine to me. But then again I am far from an expert.
BTW the model is LE42H508
 
Thread starter Similar threads Forum Replies Date
R Streaming Video & TVs 1
M Streaming Video & TVs 1
L Streaming Video & TVs 1
R Streaming Video & TVs 1
M Streaming Video & TVs 4
I Streaming Video & TVs 1
S Streaming Video & TVs 1
C Streaming Video & TVs 1
R Streaming Video & TVs 1
I Streaming Video & TVs 1
D Streaming Video & TVs 2
F Streaming Video & TVs 4
H Streaming Video & TVs 6
D Streaming Video & TVs 3
D Streaming Video & TVs 1
J Streaming Video & TVs 1
W Streaming Video & TVs 2
G Streaming Video & TVs 1
S Streaming Video & TVs 3
C Streaming Video & TVs 1

ASK THE COMMUNITY