How can I install back my video driver for Acer Aspire One AO722

stevetheplumber73

Distinguished
Oct 4, 2011
8
0
18,510
0
Hello,I did a clean reinstall and can't reinstall the amd video driver. I installed the video driver (Catalyst Control Center) but it wouldn't open. I removed it but it's not available as a download in the Acer driver website, what Can I do?(Thank you)
 

Pyree

Distinguished
Moderator
What do you mean CCC won't open? Do you mean driver not installed and graphics not working properly or driver installed but just can't open CCC at startup or can't open CCC manually?
 

stevetheplumber73

Distinguished
Oct 4, 2011
8
0
18,510
0


Driver not installed. I installed CCC in hopes that it would find my video driver and install it. After installing I cannot open it manually. It doesn't even show an error message.
 

outlw6669

Distinguished
Dec 4, 2006
179
0
18,660
8
I am having the exact same issue with my ASUS Eee Pc 1015BX.
In fact, I was just preparing to open a new thread about the issue so this works out great :D

Like your Aspire One A0722 my 1015BX it is Ontario powered, a C-60 as it may be.
The factory install worked fine but, as it was only Win 7 Starter, the first thing I did was crack it open, swap the drive and install Win 7 Home Premium (two installs of 64-bit, final install is 32-bit due to ASUS' lack of 64-bit support :pfff: ).

No matter what I try, I can not get the drivers to properly install.
I attempted to install versions 11.9-11.5, working back from the newest, and additionally the drivers supplied from ASUS on the latest 32-bit instillation.

The AMD official driver packages install with the 'Vision Engine Control Center' but it only shows information on the CPU segment.
The ASUS supplied drivers do install CCC, but it can not be opened (same issue as OP).
I also tried AMD's 'Automatically Detect and Install' option.
When ran it could not locate any supported hardware :/

After all attempted driver installs the Device Manager still listed the Display Adapter as a 'Standard VGA Display Adapter'.

And to clarify, SP 1 was installed before I attempted to install any drivers (as 11.9 requires).

So, does anyone have any thoughts or suggestions?
AMD's E and C series are pretty popular right now so I am sure someone out there has encountered and solved this issue...
 

Pyree

Distinguished
Moderator
Thank you outlw6669 for you detailed description of the problem. I now have a better understanding of the situation. It looks like the environment requirement for the driver to work properly is very strict. I am running out of idea.
 

stevetheplumber73

Distinguished
Oct 4, 2011
8
0
18,510
0


The problem is Acer took down the driver from their website for some odd reason.
 

Pyree

Distinguished
Moderator
That can happen. Acer make their laptop graphics to work only on their laptop specific driver and not on generic amd driver. So, no Acer driver at all? Not even old one?
 

outlw6669

Distinguished
Dec 4, 2006
179
0
18,660
8


Actually, he was sugusting that you download the drivers directly from AMD.
You can locate the 32-bit Drivers Here and the 64-bit Drivers Here.

Please give the official drivers a try and post back your experience.
I personally would be very interested to know if they work for you.
 

Rizlla

Distinguished
Mar 11, 2011
10
0
18,560
0


I have contacted Acer before although it was in South Africa and the service was great. Why I am asking is you said that they removed the drivers from the website. I had the same problem and they gave me details for their FTP site where they archive all the older stuff. Perhaps the drivers will be there.
 

stevetheplumber73

Distinguished
Oct 4, 2011
8
0
18,510
0


No such luck. My video card still reads as vga driver. I installed the Catalyst package from that link and I this following error message: "AMD VISION Engine Control Center cannot be started. There are currently no settings that can be configured using AMD VISION Engine Control Center."
 

outlw6669

Distinguished
Dec 4, 2006
179
0
18,660
8
Well, that sucks, I guess it is not just me :/

I am going to open a thread in the Windows 7 driver section.
If I find an answer there I will post it back here.
 

outlw6669

Distinguished
Dec 4, 2006
179
0
18,660
8

Unfortunately, it does not work on my end :(

The thread in the Win 7 Drivers section is Here, if anyone was interested...
 

stevetheplumber73

Distinguished
Oct 4, 2011
8
0
18,510
0

Thank you, but the problem remains.
 
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 1
M Laptop Tech Support 3
J Laptop Tech Support 5
C Laptop Tech Support 1
T Laptop Tech Support 2
S Laptop Tech Support 8
C Laptop Tech Support 1
A Laptop Tech Support 1
B Laptop Tech Support 3
B Laptop Tech Support 2
P Laptop Tech Support 10
G Laptop Tech Support 1
S Laptop Tech Support 1
R Laptop Tech Support 5
F Laptop Tech Support 1
V Laptop Tech Support 4
A Laptop Tech Support 5
A Laptop Tech Support 3
G Laptop Tech Support 3
G Laptop Tech Support 1

ASK THE COMMUNITY