Question Immediate "failed to conect to network" error when attempting to connect to ANY wifi network. Can't tell if hardware or software issue.

Jan 17, 2021
1
0
10
0
Hello all,

Here are the specs of the trouble phone:

Pixel 3a XL
Android Version 11
Kernel 4.9.232-ga8a0fbc4fb8e-ab696031

So yesterday I dropped my phone a little too hard and the screen stopped working. No damage, just would not turn on. I've replaced the screen myself quite a few times so I thought the internal connection had disconnected. I reset the connection but it didn't seem to fix it, so I took it to a phone repair shop. They did a diagnostic but told me they couldn't work on the phone because some of the graphite coating on the phone interior was scraped off (I accidently did that a preivous time when I was replacing to screen). They told me that the graphite was needed for connections and the motherboard might be broken so they wouldn't test any new screens and I should just recycle the phone?? mind you the phone was still working, vibrating and making noise so that didn't make any sense to me. I thanked them for nothing and left the store.

I tried to reset the screen connection and whatever they did to diagnose my phone actually made the screen work again. I think it was some kind of reset, I noticed all my app preferences were gone and my lock screen changed but I still had all my apps and such. Everything seemed to work except that I could not connect to my WiFi network. Upon entering the password and attempting to connect I am returned with a "failed to connect to network" pop-up immediately. It doesn't seem to be trying to connect at all, it just immediately fails. I can still see all the wifi networks around me, and I can connect to LTE. I can't figure out what is wrong, I've gotten this error with multiple different WiFi networks, cleared the wifi settings, tried it in safe mode, restarted; all have had no effect. I even tried a wifi app and it just returned "failed to connect, enable and disable wifi and try again", which does not change things either.

I noticed that my google play update still shows October 2020, and says I need to restart my phone to finish to update. Restarting has no effect though. I think the restart was pending when I dropped my phone, so the repair store's diagnostic may have messed something up with the update. Should I do a factory restart worse case? I can't figure out if this is even a hardware or software problem, the antennas should be fine if I can still detect WiFi sources but I don't know. Any ideas?
 
Thread starter Similar threads Forum Replies Date
F Android Smartphones 4
F Android Smartphones 2
sabalomsa Android Smartphones 2
123staxx Android Smartphones 3
S Android Smartphones 1
N Android Smartphones 1
O Android Smartphones 4
U Android Smartphones 1
M Android Smartphones 1
M Android Smartphones 1
C Android Smartphones 12
R Android Smartphones 1
S Android Smartphones 1
W Android Smartphones 1
B Android Smartphones 1
F Android Smartphones 2
B Android Smartphones 1
A Android Smartphones 1
G Android Smartphones 5
T Android Smartphones 1

ASK THE COMMUNITY