Inspiron 5570 wifi is slow compared to older laptops

Feb 8, 2018
2
0
10
0
I bought a new Inspiron 5570 last week. It has "802.11ac + Bluetooth 4.1, Dual Band 2.4&5 GHz, 1x1"

I have another 6 years old ASUS x401a-bhpdn41 laptop that has integrated Integrated 802.11 b/g/n

Now connecting both laptop through NETGEAR Router WGR614v10 that i believe is 802.11n capable, I see the older laptop connecting at 30Mbps and the new Dell only gets 10Mbps (though it connects to the router at 72.2Mbps MCS index).

They both were placed next to each other and both run windows 10. I have already tried updating network drivers for the inspiron.

I also took the dell to a friends house and found that though his 5 years old hp is able to connect to his wifi at 50Mbps, my Dell can only connect at 20Mbps.

I have already checked the firmware of the router and it was up-to-date. I also tried moving my laptop close to the router and the result is the same.

Spoke to Dell customer support. They initially said its an OS issue and when i spoke to the OS team he said its a hardware issue and the network card can only give me 20Mbps. Please help identify what the problem is. Thanks!
 
Feb 8, 2018
2
0
10
0
I was able to find the source of the problem.

I did a clean reboot without any services and network was fine.

Tracked down the reason to smartbyte by rivet networks. Its must have been added by dell update. its in their drivers list. It runs two services on startup. I uninstalled it.
 
Thread starter Similar threads Forum Replies Date
rkj94 Laptop Tech Support 0
A Laptop Tech Support 2
R Laptop Tech Support 4
Saberwulf1883 Laptop Tech Support 5
prattbetta@ Laptop Tech Support 6
V Laptop Tech Support 4
M Laptop Tech Support 11
L Laptop Tech Support 1
J Laptop Tech Support 0
G Laptop Tech Support 5
S Laptop Tech Support 2
N Laptop Tech Support 1
baltay Laptop Tech Support 0
Tohka Laptop Tech Support 1
Aizazm Laptop Tech Support 4
C Laptop Tech Support 2
R Laptop Tech Support 4
S Laptop Tech Support 1
T Laptop Tech Support 1
C Laptop Tech Support 1

ASK THE COMMUNITY