JBL LSR305 to PC Constant Static

mevans811

Commendable
Feb 11, 2016
3
0
1,510
0
I have a pair of JBL LSR305's, both running to a splitter to 1 3.5mm jack which connects to my PC. The PC has a RealTek HD Audio sound card. I'm getting constant static, but still plays sound. As I was writing this, the static in my left speaker stopped and now won't play sound.

Do I need a new sound card, adapter, driver, etc?

**UPDATE** - Might I also add that I'm using the XLR output on the speaker. My thought is to try the 1/4" TRS output instead.. thoughts?

Thanks
 
Try connecting the speakers to another source like your phone with the same cables. Bad cable could cause no output but not likely to cause noise.
If they work fine then the problem is in your PC.
If they don't work then it sounds like the speakers have a problem. Bad amps maybe. Hope they are under warranty/
 

mevans811

Commendable
Feb 11, 2016
3
0
1,510
0


I did some more research and it seems since these are studio monitor speakers and hooked into a PC's sound card, that's what will cause the static. They suggest getting an external USB sound card to solve the problem. But before that happens I may try the other 1/4" outputs on the speakers to the PC.

Currently I'm using the XLR to 1/4" Y cable to the 3.5mm PC sound card, which could also be the cause.
 
Thread starter Similar threads Forum Replies Date
T Audio 4
CrackedMarbles Audio 6
N Audio 2
S Audio 1
D Audio 8
M Audio 4
G Audio 1
P Audio 13
Z Audio 4
F Audio 1
A Audio 1
T Audio 3
B Audio 3
C Audio 4
I Audio 7
D Audio 2
S Audio 1
revolultrablue Audio 1
T Audio 1
V Audio 10

ASK THE COMMUNITY