Laptop isn't using the dedicated gpu properly

Zerex777

Commendable
Jun 28, 2016
2
0
1,510
0
Hello, guys. I just bought a Lenovo 700 which has I5-6300hq and gtx 950m 4 gb, it runs perfectly on CS GO and League of Legends with 200-300 FPS, but when I try playing AC Black Flag for example i play it with 20-30 fps, same with WOW ( Wrath of the Lich King ) which is a relatively old game. I already tried everything from the nvidia control pannel to set so that it uses the high performance dedicated graphics, but i must be doing something wrong, please help. Also when i disabled the integratted gpu from the device manager and i tried to play AC Black Flag it ran with like 1-2 fps, so it wasn't even using the dedicated video. Please help !
 

rgd1101

Titan
Moderator
MERGED QUESTION
Question from Zerex777 : "Low fps on SOME GAMES"





 
Thread starter Similar threads Forum Replies Date
E Laptop General Discussion 3
ssahay02 Laptop General Discussion 1
S Laptop General Discussion 2
C Laptop General Discussion 1
T Laptop General Discussion 1
L Laptop General Discussion 1
D Laptop General Discussion 6
Z Laptop General Discussion 8
T Laptop General Discussion 2
A Laptop General Discussion 6
D Laptop General Discussion 1
M Laptop General Discussion 2
S Laptop General Discussion 3
T Laptop General Discussion 2
HardwareExtreme Laptop General Discussion 1
A Laptop General Discussion 7
L Laptop General Discussion 4
J Laptop General Discussion 6
S Laptop General Discussion 4
santy74 Laptop General Discussion 4

ASK THE COMMUNITY