Question Laptop stuck in Aptio Loop - Among other issues

Nov 4, 2018
1
0
10
0
My laptop is currently stuck in an Aptio Setup Utility loop - when I use F10 to exit the loop, it goes to ASUS loading screen for about 3seconds before reverting back into the Aptio Setup Utility.

My computer's graphic card has an outdated driver, but has an Error 43 issue so I can't update the driver as it crashes each time I try to update the driver - I'm assuming this is what's causing all my issues

Also, my laptop's "Sleep" function is missing, the button and the function.

My computers specs:
Brand: ASUS
Model: X555D
Ram: 8GB
Graphics Card: AMD Radeon R6
OS: Windows 10

If anyone is able to help me fix this issue, i would hugely appreciate it.

Also, the ASUS Smart Gesture function needed reinstallation about a week ago because that function failed as well.
 
Sounds to me like either the drive is going/gone or the motherboard. Hopefully not both.

Were it me I would pull the drive and connect it to another device to see if it is accessible. If it is, great, you can then back up your personal stuff off of it, put it back in your laptop and then try reinstalling the whole system. You would need a USB or CD/DVD with the original OS on it.

Should it not work (but the drive did show as fine) then I would look into replacing the motherboard.

If you don't feel comfortable doing the work yourself, then I would try a local tech.
 
Thread starter Similar threads Forum Replies Date
E Laptop Tech Support 1
TheKiwi01 Laptop Tech Support 3
chippy-mx Laptop Tech Support 2
S Laptop Tech Support 1
N Laptop Tech Support 2
SnackinMcCracken Laptop Tech Support 1
P Laptop Tech Support 1
L Laptop Tech Support 1
V Laptop Tech Support 7
D Laptop Tech Support 2
H Laptop Tech Support 1
S Laptop Tech Support 1
S Laptop Tech Support 1
E Laptop Tech Support 1
J Laptop Tech Support 1
M Laptop Tech Support 7
B Laptop Tech Support 11
B Laptop Tech Support 3
J Laptop Tech Support 1
D Laptop Tech Support 1

ASK THE COMMUNITY