Question Laptop trying to start but doesn't after disassembling and cleaning.

Feb 6, 2021
1
1
10
0
I have a Dell Inspiron 3521. I disassembled it so I could clean the fan.

After putting it back together, the power showed it was connected but it didn't switch on. I disassembled again and made sure everything was connected properly. After reassembly, it tried to start and then it seems to just stop.

How far does the power button cable need to be in the socket, is the little white line on it some kind of guide?

I did clean with a very soft bristle paint brush, brand new, which I now realise could have shorted something. So possibly, that might be the cause.

Is there anything else I can try? (A new laptop is not really feasible due to finances)

Any advice would be greatly appreciated.

Edit Never mind. It turned out to be my RAM. I had not put it back in properly. Thank goodness. I was very worried after I had read some of the similar forum posts.
 
Last edited:
Reactions: Hydra119
Thread starter Similar threads Forum Replies Date
O Laptop Tech Support 1
TaranWolf Laptop Tech Support 1
memo1402 Laptop Tech Support 0
S Laptop Tech Support 0
Georgeop799 Laptop Tech Support 3
S Laptop Tech Support 2
All_Might Laptop Tech Support 1
Lhcannon Laptop Tech Support 0
A Laptop Tech Support 1
D Laptop Tech Support 0
B Laptop Tech Support 0
K Laptop Tech Support 0
R Laptop Tech Support 2
S Laptop Tech Support 0
V Laptop Tech Support 0
Arthurdensley Laptop Tech Support 1
H Laptop Tech Support 6
Spacebit Laptop Tech Support 1
A Laptop Tech Support 7
I Laptop Tech Support 2

ASK THE COMMUNITY