Laptop using intergrated graphics instead of dedicated

Jan 3, 2019
6
0
10
0
I have a laptop with the below specs:
Prossesor : Amd a6-6310 with r4 graphics
Dedicated graphics : R5 M330
Ram : 6 gb (4,95 usable)
Hard drive : 500 gb
Version of amd driver : 18.5.1 every newer version will cause mouse lag
In a lot of games i have noticed that the r4 graphics are being used instead of the r5 dedicated graphics
Games i tested:
Rust
CS:GO
CoD:MW2
 

poopflinger

Prominent
Sep 18, 2017
4
0
520
1


Make sure you have the latest radeon drivers installed
 

jay32267

Admirable
I think it's very strange that it's only in some games though. I thin this tends to point away from the BIOS.

How do you know it's switching back and forth? Do you have monitors plugged into both jacks or are you switching the cable back and forth?
 
Jan 3, 2019
6
0
10
0
No it happens on all the games, but the games i mentioned are the ones i know for a fact are using the wrong graphics card. Moreover i just use the laptops display without any externaly ones pluged in
 
Jan 3, 2019
6
0
10
0
Well on rust the info tab is listing under graphics card r4 graphics and task manager show that the r5 graphics are not used at all while the r4 graphics are the only ones used while gaming
 

shknawe

Commendable
Oct 22, 2016
84
0
1,610
13
Go to device manager, right click on r5 graphics card and hit enable. That should set it up correctly. If it says disable then it is already running as primary graphics driver.
 

poopflinger

Prominent
Sep 18, 2017
4
0
520
1
One way to use to the dedicated instead of the integrated graphics is to disable the integrated graphics in the device manager. You simply select it and hit "disable". Your screen will flicker and your dedicated graphics should kick right in.
 
Jan 3, 2019
6
0
10
0
Well i went to the device manager and disabled the igpu and then my laptop reported runing on microsoft display adaptor driver Idk why
 

poopflinger

Prominent
Sep 18, 2017
4
0
520
1


Make sure you have the latest radeon drivers installed
 

poopflinger

Prominent
Sep 18, 2017
4
0
520
1


So you disabled crossfire and everything works fine now? Did you still have to disable the iGPU in the device manager?
 
Thread starter Similar threads Forum Replies Date
K Laptop Tech Support 4
Simo Erberg Laptop Tech Support 4
ezeky1 Laptop Tech Support 0
Josip975 Laptop Tech Support 20
M Laptop Tech Support 5
F1yingSquid Laptop Tech Support 0
F3ArxDragons Laptop Tech Support 3
S Laptop Tech Support 2
beejayel30 Laptop Tech Support 0
A Laptop Tech Support 4
L Laptop Tech Support 0
Swarit123 Laptop Tech Support 2
I Laptop Tech Support 3
Dheandy Laptop Tech Support 1
Wolf113498 Laptop Tech Support 1
B Laptop Tech Support 0
T Laptop Tech Support 0
A Laptop Tech Support 1
mikmikasd Laptop Tech Support 2
B Laptop Tech Support 3

ASK THE COMMUNITY