looking for a remedy

Well you could try booting the phone in "Safe Mode" and see if it will turn on correctly. However I am not so sure it will. If your phone is under warranty, then I would be contacting the manufacturer to see about repairing or replacing it.

However, should you want to try the load in "Safe Mode" here is how.

To get into "Safe Mode" please do the following.

1. First turn off the phone.

2. Next press and hold "Power" until you see the manufacturers logo on the screen, then release the power button.

3. "Quickly" press "Volume Down" and hold it for few seconds until you see the message "Safe mode: ON" or something similar.

4. If you wanted disable it, simply repeat the steps above, and you should see "Safe Mode: OFF" rather than on.
 
Well you could try booting the phone in "Safe Mode" and see if it will turn on correctly. However I am not so sure it will. If your phone is under warranty, then I would be contacting the manufacturer to see about repairing or replacing it.

However, should you want to try the load in "Safe Mode" here is how.

To get into "Safe Mode" please do the following.

1. First turn off the phone.

2. Next press and hold "Power" until you see the manufacturers logo on the screen, then release the power button.

3. "Quickly" press "Volume Down" and hold it for few seconds until you see the message "Safe mode: ON" or something similar.

4. If you wanted disable it, simply repeat the steps above, and you should see "Safe Mode: OFF" rather than on.
 

ASK THE COMMUNITY

TRENDING THREADS