looking for battery solution

shebe12978asa

Prominent
Dec 18, 2017
1
0
510
0
my ASUS X540S sometimes cannot boot without connecting to the power and some times it can boot yet the battery says its 100%. Sometimes when i try to disconnect the power it shuts down and sometimes it stays just for a short time then goes off.
 

geofelt

Distinguished
Oct 9, 2006
647
0
19,910
187
Laptop batteries do not last forever.
Likely, yours is failing.
Be careful about replacing it with a cheaper generic battery.
Sometimes the battery is very closely tied to the laptop for proper operation.
Best to buy a genuine replacement if you can.
 

Mark RM

Estimable
Jul 16, 2014
222
1
5,110
67
I'd generally think it was the battery not putting up the amps, but it could also be a DC/DC power board. Just because it says 100% doesn't mean it's 100 per cent working. I've seen this behaviour in all kinds of devices.

I'd almost always get a new battery first, reason being, it starts fine plugged in with the superior current supplied by the aadapter.
 

geofelt

Distinguished
Oct 9, 2006
647
0
19,910
187
Laptop batteries do not last forever.
Likely, yours is failing.
Be careful about replacing it with a cheaper generic battery.
Sometimes the battery is very closely tied to the laptop for proper operation.
Best to buy a genuine replacement if you can.
 
Thread starter Similar threads Forum Replies Date
AsusExcitement65 Laptop Tech Support 2
F Laptop Tech Support 3
T Laptop Tech Support 1
M Laptop Tech Support 0
qnkov Laptop Tech Support 0
M Laptop Tech Support 0
ruslruslrusl1 Laptop Tech Support 3
kenzomenzo Laptop Tech Support 1
G Laptop Tech Support 1
J Laptop Tech Support 1
R Laptop Tech Support 1
J Laptop Tech Support 3
K Laptop Tech Support 2
B Laptop Tech Support 1
S Laptop Tech Support 1
P Laptop Tech Support 1
J Laptop Tech Support 1
N Laptop Tech Support 1
A Laptop Tech Support 3
Dell-LornaM Laptop Tech Support 2

ASK THE COMMUNITY

TRENDING THREADS