Question Low GPU and CPU usage, Low FPS in all games

Apr 22, 2019
1
0
10
0
I just purchased a HP CX0056WM laptop

Here are the Specs:

Intel i5-8300H,
NVIDIA GTX 1050Ti
8GB Ram
Windows 10

I was actually pretty excited because I found it on sale for $250 at Walmart through brickseek. I’ve been wanting to build a cheap gaming PC for sometime but when I saw this deal I couldn’t pass it up. This is my first gaming pc and Im completely lost.

I’m experiencing low (Around 30%) CPU and GPU usage in every game I’ve tried and having horrible frame rate (Around 15-25FPS)

Temps are under 50 degrees

I’ve turned power settings in windows to maximum performance and set the Nvidia as the preferred card in the NVIDIA control panel. I’ve also selected to prefer performance in those settings as well.

I’ve tried updating the GPU drivers directly from NVIDIA and through HPs website. I’ve tried uninstalling the drivers with DDU and reinstalling. In fact the best performance I’ve had is when I reverted back to the default drivers through the HP recovery utility.

Games I’ve tried:

GTA V: When opening for the first time it warned me that my system did not meet the minimum requirements despite it meeting the recommended requirements. Ran benchmark test on high settings, averaged 22-30FPS however the 1050ti card was at 2% usage??? The integrated intel GPU was at 0%

Squad: Lowest settings averaging 15-20FPS

Beam NG: varied different times I ran the game. Averaged 20FPS on low settings, however sometimes I can get 50FPS on high settings. Very inconsistent.

Minecraft: For the sake of testing, ran at 25FPS on LOWEST settings.


Another strange thing, in every game I play adjusting the graphic settings from high to low does not make a difference in FPS but will show a huge decrease in GPU usage. So I’ll go from %60 to 30% GPU usage but the FPS will stay the same (under 30FPS)


I wish I knew more, idk if it’s a hardware issue or what but I really hope someone can guide me in the right direction.

Thank you in advance!
 
May 18, 2019
1
0
10
0
Hello from Germany,

i had this Problem too once i got my HP Envy 15 with 4GB GTX850. At first a (stupid) question:
Did you start the game by doubleclicking the shortcut? I did until i noticed the option "run with graphics processor" on rightclicking the shortcut.

By just doubleclicking it will run the game with the standard running slow graphic unit of the cpu.

On my Envy another problem was the power supply, i used a not original one which made the cpu usage not rise over 30%. Even opening browser was very slow.
A new and HP original solved this Problem.

Best regards from germany
 
Thread starter Similar threads Forum Replies Date
NeedHelpGuy Laptop Tech Support 0
S Laptop Tech Support 0
smohsen Laptop Tech Support 0
mk716 Laptop Tech Support 1
V Laptop Tech Support 1
F Laptop Tech Support 1
S Laptop Tech Support 12
B Laptop Tech Support 6
M Laptop Tech Support 12
X Laptop Tech Support 4
R Laptop Tech Support 1
Z Laptop Tech Support 6
J Laptop Tech Support 12
G Laptop Tech Support 3
D Laptop Tech Support 8
S Laptop Tech Support 1
W Laptop Tech Support 1
G Laptop Tech Support 10
S Laptop Tech Support 28
TheGman_GL Laptop Tech Support 5

ASK THE COMMUNITY