My Asus notebook model V550C

bigphatdaddy1966

Prominent
Jun 24, 2017
3
0
510
0
It's not coming on at all. I understand it may be the battery or power cord but no lights are coming on, I mean it's like a piece of trash now. But when it was coming and I tried all these steps, BIOS, the Basic Input and Output System settings, Troubleshooting options. I tried to refresh, reset, even tried using advanced options using System Image Recovery to try to recover my system, trying to access the POST. I tried restarting my notebook by pressing the POST. Tried waiting for Windows to load by Choosing an option screen then tap troubleshooting, then tap Advanced options to select System Recovery. I tried all these steps and procedures when my notebook was lighting up and coming on before it went completely dead. Like I said before, all this is very frustrating and confusing to me because I lost everything, my apps, google, please forgive me for repeating the same things over and over again. Just want someone in the community to try and help me figure my notebook out before I can call it TRASH. Thank you so very much for reading.
 

rgd1101

Polypheme
Moderator
  • Deleted by N/A
MERGED QUESTION
Question from bigphatdaddy1966 : "My Asus notebook model V550C isn't working at all"





 
Thread starter Similar threads Forum Replies Date
DariusEldritch Laptop Tech Support 0
S Laptop Tech Support 5
P Laptop Tech Support 1
N Laptop Tech Support 1
V Laptop Tech Support 1
J Laptop Tech Support 1
K Laptop Tech Support 1
P Laptop Tech Support 2
M Laptop Tech Support 2
M Laptop Tech Support 1
K Laptop Tech Support 1
S Laptop Tech Support 1
L Laptop Tech Support 1
B Laptop Tech Support 8
V Laptop Tech Support 2
D Laptop Tech Support 1
M Laptop Tech Support 1
MsGardener7 Laptop Tech Support 7
K Laptop Tech Support 7
W Laptop Tech Support 2

ASK THE COMMUNITY