My screen is black but it is still active

DarkIllusions

Commendable
Sep 18, 2016
9
0
1,510
0
So, this happened about a month ago and ive just kinda ignored it. It hasn't gotten worse or better. Whenever i turn on my laptop, (it is a Msi gp70 2pe leopard) the screen is black. But it is not completely black, the back light is on and the computer is totally on. If i connect a second monitor and use it as my primary monitor it works fine. But the weirdest thing is that i can use it, like i can click on it move windows and all that, but there is just no display. But even weirder is if i leave it on for like 5 minutes then restart it, it is totally back to normal until i turn it off again. this is really annoying for classes because in some i need it and in some i dont so, having to wait 5 minutes before i can use it gets annoying. Ive tried taking out my battery and doing that reset thing. and ive tried several other things but none has worked. So if anyone has a clue help would be appreciated.
 

DarkIllusions

Commendable
Sep 18, 2016
9
0
1,510
0


Does that mean that it might be the inverter being deffective since it sometimes turns on and sometimes doesnt?
 

DarkIllusions

Commendable
Sep 18, 2016
9
0
1,510
0


thanks for the reply i will look into it
 

DarkIllusions

Commendable
Sep 18, 2016
9
0
1,510
0


Could it still be the backlight even though when i turn it on i can look into the screen and see lights appearing that the backlight is on, or is it just going?
 

DarkIllusions

Commendable
Sep 18, 2016
9
0
1,510
0
Well i wanted to note something. When i dont leave my laptop for 5 minutes and keep trying to restart it. the screen will go to the recovery screen and tell me that windows didnt load correctly. Could this potentially be the OS failing to load?
 

DarkIllusions

Commendable
Sep 18, 2016
9
0
1,510
0
The only reason i ask is because the screen isnt completely black, like if the display wasnt working. It is glowing and it is the same light as if i was just starting the computer up just without the logo, but the screen is lit up and everything.
 

DarkIllusions

Commendable
Sep 18, 2016
9
0
1,510
0


Yes it turns on everything like a normal startup, but just no image. Sound, fans are on, backlight is on, everything. And if I use a second monitor it functions like normal. But the laptop still has no image..
 

DarkIllusions

Commendable
Sep 18, 2016
9
0
1,510
0
Well by the way, i found a sorta hotfix to the problem and i also found out when the problem was occuring. It would occur whenever the laptop attempted to go into hibernation, and something occured in the display causing it to not display any image. I found that disabling hibernation from the computer causes the problem to not happen. So what im going to do is just stick with this until i find a solution or until the display actually gives out. Thanks for all the help i really appretiate it.
 
Thread starter Similar threads Forum Replies Date
sulphur88 Laptop Tech Support 1
MasterLewis Laptop Tech Support 1
N Laptop Tech Support 2
M Laptop Tech Support 7
MrChard39 Laptop Tech Support 0
Reh@n Laptop Tech Support 3
TehAsezOner Laptop Tech Support 0
Philbert24 Laptop Tech Support 1
Indigo79 Laptop Tech Support 9
M Laptop Tech Support 3
D Laptop Tech Support 6
Thaboss6 Laptop Tech Support 1
G Laptop Tech Support 1
G Laptop Tech Support 6
khushit Laptop Tech Support 3
Poxeh Laptop Tech Support 5
A Laptop Tech Support 1
D Laptop Tech Support 1
K Laptop Tech Support 5
G Laptop Tech Support 2

ASK THE COMMUNITY