Need help fixing a problem with my laptop

Llchurch425

Estimable
Nov 9, 2015
2
0
4,510
0
I have an Alienware laptop and I was on YouTube watching videos and I noticed when I closed the browser it looked like someone took a screen shot of the screen put it over my wallpaper and lowered the opacity and now when ever I turn it off or restart it, it has the Alienware logo with the YouTube page in the background I have pics if anyone needs to see what I'm talking about and any help would be greatly appreciated.
 
Hi,

It seems like the it's a burnt image of Youtube on your screen. It's a hardware failure already if it still shows up even on the boot up process. I would suggest to test the graphics card as well by connecting an external monitor and see if the same problem will persist. If there's no image on the second monitor that means you're built in display is damaged already and replacing it will be the only solution.
 
Thread starter Similar threads Forum Replies Date
boyyaacob89 Laptop General Discussion 1
S Laptop General Discussion 1
sina766 Laptop General Discussion 2
W Laptop General Discussion 1
Lutfij Laptop General Discussion 0
H Laptop General Discussion 1
J Laptop General Discussion 0
J Laptop General Discussion 0
J Laptop General Discussion 0
J Laptop General Discussion 0
J Laptop General Discussion 0
A Laptop General Discussion 1
E Laptop General Discussion 2
S Laptop General Discussion 8
C Laptop General Discussion 1
C Laptop General Discussion 3
K Laptop General Discussion 1
J Laptop General Discussion 9
L Laptop General Discussion 21
G Laptop General Discussion 1

Similar threads


ASK THE COMMUNITY