Need help identifying the root of high GPU usage while idle

DyHaglar

Honorable
Jul 2, 2013
11
0
10,560
0
I am experiencing GPU usage over 90% and temperatures over 70 degrees while idle. I believe this is due to a virus (possibly a BitCoin miner) using up my resources. Any help on how to fix this or find the root of the issue would be amazing!
 

lxxjordan23xxl

Honorable
Jul 6, 2012
6
0
10,520
1

It is probably a virus like you thought it was since I literally typed "svchost.exe g" and google came up with "svchost.exe gpu usage" and another thread where a guy had the same problem and fix it through antivirus.

Here is the thread: http://www.tomshardware.com/forum/366344-28-usage-usage-svchost
 

DyHaglar

Honorable
Jul 2, 2013
11
0
10,560
0
So far only Afterburner, though I've been experiencing performance issues and increased loudness, so it would make sense. Any other programs I could try to make sure it's accurate?

 

lxxjordan23xxl

Honorable
Jul 6, 2012
6
0
10,520
1
Try GPU-Z but if you can physically tell your system is running hard then make sure you don't somehow have some kind of benchmark running in the background or even a game(just taking a stab in the dark on that though).
 

DyHaglar

Honorable
Jul 2, 2013
11
0
10,560
0


Any way to find a file on my system that lists them all so I can copy it, or do I just have to type it out?

 

DyHaglar

Honorable
Jul 2, 2013
11
0
10,560
0
System Idle Process 0 Services 0 24 K
System 4 Services 0 1,156 K
smss.exe 272 Services 0 1,188 K
csrss.exe 384 Services 0 4,600 K
wininit.exe 464 Services 0 4,572 K
csrss.exe 484 Console 1 13,856 K
services.exe 520 Services 0 13,080 K
lsass.exe 536 Services 0 11,744 K
lsm.exe 544 Services 0 4,528 K
winlogon.exe 648 Console 1 7,708 K
svchost.exe 708 Services 0 10,728 K
svchost.exe 788 Services 0 8,448 K
atiesrxx.exe 892 Services 0 4,480 K
svchost.exe 932 Services 0 27,588 K
svchost.exe 976 Services 0 290,240 K
svchost.exe 1016 Services 0 17,748 K
svchost.exe 284 Services 0 44,268 K
audiodg.exe 320 Services 0 19,728 K
svchost.exe 1056 Services 0 15,916 K
atieclxx.exe 1132 Console 1 8,016 K
spoolsv.exe 1324 Services 0 11,568 K
svchost.exe 1352 Services 0 34,360 K
Fuel.Service.exe 1412 Services 0 13,264 K
svchost.exe 1452 Services 0 14,232 K
hamachi-2.exe 1480 Services 0 9,704 K
HiPatchService.exe 1548 Services 0 42,324 K
PnkBstrA.exe 1680 Services 0 4,208 K
SeaPort.exe 1760 Services 0 11,116 K
ViakaraokeSrv.exe 1836 Services 0 4,772 K
svchost.exe 2172 Services 0 4,828 K
svchost.exe 2216 Services 0 5,468 K
WUDFHost.exe 2412 Services 0 6,312 K
taskhost.exe 2796 Console 1 13,896 K
dwm.exe 2896 Console 1 40,780 K
explorer.exe 2960 Console 1 74,012 K
XBoxStat.exe 2488 Console 1 7,720 K
soffice.exe 2952 Console 1 3,376 K
soffice.bin 2980 Console 1 37,200 K
VDeck.exe 3036 Console 1 7,916 K
jusched.exe 3024 Console 1 12,804 K
hamachi-2-ui.exe 2668 Console 1 9,300 K
TSVNCache.exe 3348 Console 1 8,988 K
SearchIndexer.exe 3664 Services 0 31,492 K
wmpnetwk.exe 2724 Services 0 6,656 K
MOM.exe 3456 Console 1 6,064 K
svchost.exe 2768 Services 0 15,052 K
svchost.exe 2652 Console 1 56,284 K
conhost.exe 3412 Console 1 5,092 K
CCC.exe 3712 Console 1 20,764 K
RTSS.exe 2320 Console 1 10,596 K
ccsvchst.exe 3596 Services 0 10,992 K
svchost.exe 4892 Services 0 28,876 K
ccsvchst.exe 4156 Console 1 10,236 K
MSIAfterburner.exe 312 Console 1 16,344 K
wuauclt.exe 1716 Console 1 6,764 K
Steam.exe 4608 Console 1 72,804 K
chrome.exe 3272 Console 1 163,892 K
chrome.exe 2708 Console 1 146,668 K
chrome.exe 4588 Console 1 92,716 K
chrome.exe 1088 Console 1 61,680 K
chrome.exe 3940 Console 1 18,440 K
chrome.exe 832 Console 1 58,400 K
perfmon.exe 4556 Console 1 185,952 K
mbamscheduler.exe 996 Services 0 6,396 K
mbamservice.exe 4216 Services 0 55,756 K
mbamgui.exe 2816 Console 1 8,788 K
mbam.exe 1164 Console 1 282,584 K
chrome.exe 188 Console 1 58,108 K
chrome.exe 4536 Console 1 51,348 K
chrome.exe 2380 Console 1 52,900 K
chrome.exe 300 Console 1 47,092 K
chrome.exe 4084 Console 1 91,200 K
taskmgr.exe 2788 Console 1 13,896 K
mmc.exe 5776 Console 1 28,684 K
chrome.exe 6056 Console 1 91,980 K
chrome.exe 5788 Console 1 62,604 K
chrome.exe 5540 Console 1 76,268 K
chrome.exe 6124 Console 1 74,336 K
chrome.exe 4488 Console 1 20,108 K
cmd.exe 5616 Console 1 3,072 K
conhost.exe 5404 Console 1 5,816 K
WmiPrvSE.exe 5224 Services 0 7,212 K
tasklist.exe 760 Console 1 5,988 K

Kinda sloppy, sorry about that. Also, I would assume the large amount of chrome.exe's is because of the 11 tabs I have open.
 

DyHaglar

Honorable
Jul 2, 2013
11
0
10,560
0


Yes, but I suppose giving it another shot wouldn't hurt. However, after months of experiencing performance issues likely stemming from this, I'm not expecting much.
 

Bejusek

Distinguished
Sep 4, 2009
29
0
18,610
8
Process list looks good. Nothing suspicious.
Next step is to use process explorer http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx
Click View > Select Columns > GPU and check the boxes next to whatever you'd like to watch: GPU Usage, GPU Private Data, GPU Committed Bytes, or GPU Shared Bytes. Sort processes by GPU usage. Investigate what is causing problems.

Additionally you can double click any process and monitor how it uses your GPU in GPU tab.
 

lxxjordan23xxl

Honorable
Jul 6, 2012
6
0
10,520
1

Only thing I can suggest is trying the usual troubleshooting methods of using different drivers, a different card, etc. Also, if you think it could be a virus you could try using integrated graphics to see if the load switches to your CPU but I could just be speaking nonsense by suggesting that.
 

DyHaglar

Honorable
Jul 2, 2013
11
0
10,560
0


One of the svchost.exe's was using up a decent amount of my GPU. I killed the process and, according to Afterburner, GPU usage was at 0%. However, Ijust started noticing spikes up to 60%. Temperature is normal but the spikes are continuing.
 

lxxjordan23xxl

Honorable
Jul 6, 2012
6
0
10,520
1

It is probably a virus like you thought it was since I literally typed "svchost.exe g" and google came up with "svchost.exe gpu usage" and another thread where a guy had the same problem and fix it through antivirus.

Here is the thread: http://www.tomshardware.com/forum/366344-28-usage-usage-svchost
 

DyHaglar

Honorable
Jul 2, 2013
11
0
10,560
0


It appears that way, Malwarebytes detected and removed it but upon restarting the system the usage returned. I made a post on their forums but I was hoping to solve it here. Oh well, thank all of you for your help! I guess I'll watch my post and see if I can fix it. Thanks!

 

WaynerPusk

Estimable
Apr 24, 2015
1
0
4,510
0
Hello. I've had this same issue, but this post was helpful in eradicating it. Thank you for introducing me to process explorer, Bejusek. I was able to discover one "mdm.exe," which wasn't using any % of GPU, but had a bit of GPU memory committed to it. I ended it and instantly my GPU usage fell down to 1%, from 99% as measured in MSI Afterburner. For some reason MBAM failed to identify it. Thanks again and good luck to anyone else with this issue.
 

ASK THE COMMUNITY