Need help with my turntable and receiver

chirsxblade

Estimable
Dec 27, 2014
3
0
4,510
0
Alright, I am really new to the audio world so excuse my ignorance. I am attempting to hook up a Onkyo HT-R393 Receiver to my sony pslx300usb turntable. The receiver is working just fine as I am able to use my streaming stick which is connected via an HDMI cord from the receiver into the TV. The speakers work along with the sub woofer. However, when attempting to use my turntable I hear nothing. The turn table has RCA cables attached to it. I have taken those RCA cables and plugged it into the RCA ports on my receiver. Currently it is plugged into the channel labeled "TV/CD" as I am assuming the name of the port is irrelevant and just present for organizational purposes. Now when I switch from the port that the stream stick is on where the speakers are working, and switch to the port the turn table is on I hear nothing. The turn table is fine. It's working just as expected as well. The turntable has a preamp in it, and I have it switched to the line switch on the back. The speakers however play zero sound from it. What should I do?

 

chirsxblade

Estimable
Dec 27, 2014
3
0
4,510
0
No, there is a USB port on the back. It currently has nothing in it. The only switch on the turn table is one for the line and phono. Currently it's on line.
 
Thread starter Similar threads Forum Replies Date
TJtheGamer Audio 2
L Audio 3
S Audio 3
Ontodont Audio 1
A Audio 5
J Audio 3
C Audio 4
J Audio 7
B Audio 3
C Audio 1
T Audio 2
P Audio 8
P Audio 2
K Audio 2
B Audio 1
M Audio 2
M Audio 2
R Audio 3
J Audio 1
E Audio 1

ASK THE COMMUNITY