New HDD not detected after shutdown, fine after a restart

ComputersSuck

Prominent
Jun 15, 2017
2
0
510
0
If there's anything that needs further clarification, don't hesitate to ask.

The Summary:
There's an HP laptop loaded with Windows 10, Windows 10 told us we needed to replace the HDD. I cloned that HGST HDD to a new Seagate HDD of identical spec with identical partitioning and made it bootable (process was automated by True Image) then installed it into his laptop. Now, whenever the system is first started, it cannot detect the HDD. It sits at the HP splash screen for far longer than normal and at first it would go to the PXE boot mode, that being the last in the boot order, but then I decided to disable the PXE boot device altogether via the HP UEFI BIOS, and now it terminates at a screen telling me that a boot device could not be found and to press F2 for diagnostics. If I press F2 at that point, I can run a BIOS-based HDD check (black screen, white text, keyboard only, is this still UEFI?) and it will pass. But if I conduct that same test from a cold-boot, not allowing it to cycle through the boot order, and attempt an HDD check it will fail and tell me that the drive couldn't be detected. Also, if I cold-boot the device and then ctrl-alt-del immediately upon seeing the HP splash screen, the system of course warm-boots, and it boots the HDD right away. But I should also mention that there was another HP diagnostics-like page that I was able to reach (I don't remember where exactly) that was UEFI and the HDD would always pass the test from that particular screen, whether cold or warm booted.

The Details:
My coworker told me that his HP Probook 650 G1 Windows 10 laptop had given him an error of some sort telling him that he needed to replace his HDD. It seemed to still be working just fine but because he has some important data I decided to go ahead and get him a new HDD with identical specifications. I then cloned the drive using True Image, copying all of the partitions exactly and making it bootable, and installed the new drive in his laptop. When I started up the laptop, it took me to the HP splash screen where I can 'Press ESC to enter startup menu' like always, but it hung there for way longer than normal and eventually moved on to the PXE boot device, which is below the HDD in boot order. I hit ctrl-alt-delete to restart it, it came back to the HP splash screen, and after just a couple of seconds it began booting to the HDD. I allowed it to load, was able to log in to the desktop, all of the files and programs were transferred by the cloning process just fine. I then shut down the laptop, started it again, then hit ESC at the splash screen, then F10 to go on to BIOS setup. I immediately checked the load order to ensure what I already knew, that the PXE boot option was below the HDD, and it was but I went ahead and disabled the PXE boot options altogether just to be sure. I then did a 'save and exit' and when the splash screen came back up it booted to the HDD almost immediately (because this is effectively a restart? idk). But, when I shut the laptop down again from Windows and started it back up, it failed to boot to the HDD again. It stalled for far longer than normal at the HP splash screen, and then moved on to 'no boot drive detected, press F2 for diagnostics'. If I press F2 for diagnostics, I can run a quick hard drive check, and it will pass both tests. But I've discovered that it will /only/ pass that test if it reaches that 'no boot drive detected' screen, if I cold-boot the laptop, hit ESC for the startup menu, then F2 for system diagnostics, conduct a hard drive check, it will fail to detect the drive. But at any point before the O/S is loaded, even at the HP splash screen, I can hit ctrl-alt-delete, and the system will restart and successfully boot from the HDD right away. Right now, that's the workaround that we're using but it's far less than ideal and this botched repair job is reflecting poorly upon me in this professional environment.

What I've tried so far:
I've been back and forth over this issue, changing every option that seems relevant and reverting to BIOS defaults, but to no avail. I've tried three different BIOS versions, the one that comes loaded with the laptop, the latest version (1.39), and the one prior to the latest version (1.36). Upon loading the new BIOS it starts up just fine because what it's doing after the install is completed is, I guess, more akin to a restart than a shutdown. I was even on the line with HP support for a couple hours, he had me unplug and replug the RAM, battery, CMOS battery, the HDD, and had me reset the BIOS security. Eventually he told me that it was likely a Windows issue and that I needed to contact Microsoft. I did pursue this idea, I didn't contact Microsoft but instead searched for Windows-based solutions online. I found that a lot of people having a similar issue have resorted to disabling 'Fast boot' from the Windows 10 power options. I tried that, it made no difference whatsoever, and I honestly didn't expect it to since we're making changes on a HDD that can't even be detected at the point that the issue is occurring. It's because of this that I feel that the problem is isolated to the BIOS.

What it feels like is happening:
It feels to me almost like there's two layers (excuse my ignorance) of BIOS, the BIOS that you get when you cold-boot that cannot detect the HDD, and the BIOS you get when the PC is warm-booted that detects the HDD immediately and boots from it without hesitation. That warm-boot can be done in any way, whether from the O/S, from the BIOS, or from the startup splash screen doesn't seem to matter, the BIOS you get /will/ boot from the HDD.



Please help T_T
 

ComputersSuck

Prominent
Jun 15, 2017
2
0
510
0
Did I leave too much detail? Too little? I've still made no headway on this and would appreciate your advice and suggestions.

... Bumpity bump.
 
Thread starter Similar threads Forum Replies Date
lucasblack29 Laptop Tech Support 1
R Laptop Tech Support 8
A Laptop Tech Support 0
Secritek Laptop Tech Support 3
aztrovoi Laptop Tech Support 6
Maxwell902 Laptop Tech Support 1
R Laptop Tech Support 1
S Laptop Tech Support 3
baakudai Laptop Tech Support 5
I Laptop Tech Support 0
Atharva1313 Laptop Tech Support 0
A Laptop Tech Support 1
Kingpizza Laptop Tech Support 5
W Laptop Tech Support 1
T Laptop Tech Support 2
T Laptop Tech Support 5
newbie_techie Laptop Tech Support 6
N Laptop Tech Support 3
C Laptop Tech Support 17
lusorain23 Laptop Tech Support 1

ASK THE COMMUNITY