Question Philips 32pfl4007d/77

Feb 19, 2020
3
0
10
0
Hello everyone. I'm literally at a lost cause now. I have a Philips LCD flat screen tv, model no.32pfl4007d/77.

The problem it has, is that it switches on perfectly fine with audio and pictures but the side buttons don't work and neither does the remote but if I keep pressing the volume button when the TV is switched on, until I get a picture I can use the volume buttons and the remote to turn the volume up and down but if I press the menu button and select any of the settings eg, usb, internet, YouTube etc the TV becomes unresponsive but continues to show the images perfectly and the audio continues to work.
Also, if I press the standby button on the remote or the side of the TV it switches off but I have no standby light and I can't switch it back on. I have to unplug the TV from the mains and then plug it in again and the TV comes back on.
Sory about the essay but I know it's important to give as much info as possible. Thanks everyone😊
 

URsurrounded

Great
Feb 10, 2020
18
0
60
0
I have to assume you replaced the batteries in the remote. So either the remote is toast or the electronics receiving its signal within the TV are toast. If you can find another remote cheap, give that a try. Or pick up a universal remote and see if that works without the issues you are having. If a universal or replacement remote doesn't fix it, you will likely spend more fixing the internal issue in the set than it is worth. If you are very attached to the set, you may want to check out a place that fixes them and get an estimate. My O, if it will cost 1/3 to 1//2 the value of a new set, forget it. Sell it, give it to a school and write it off your taxes and go get yourself something current that works. We live in an age of disposable electronics.
 
Feb 19, 2020
3
0
10
0
try updating the firmware via USB
https://www.p4c.philips.com/cgi-bin/cpindex.pl?ctn=32PFL4007D/77&hlt=Link_Software&mid=Link_Software&scy=TR&slg=AEN

Could be a hardware issue/overheating components

or blown tantal capacitors

or just a bad connection between the buttons board and the mainboard

disconnect any USB devices plugged in and try again
Thank you for replying. I've tried updating the firmware but the TV doesn't even recognise any usb device. I've also made sure the file system is fat32. It's weird, if I press the volume buttons as soon as I switch the TV on, the volume buttons work but If I press any of the other buttons on the TV or the remote, the buttons become unresponsive again. Also, when pressing buttons on the remote, the standby light still blinks as normal but the TV doesn't seem to understand the command.
 

ASK THE COMMUNITY