Problem with laptop touchpad

Either you are lifting your finger just enough that the touchpad thinks you are done, or the touchpad is getting a little flakey.

If using a Synaptics Pointing Device then go to Task Bar, show all (up arrow), right click on Synaptics icon, and uncheck Tap-to Click.
You can go to Control Panel, all control panel items, mouse.
Make sure clicklock is not selected because that could be the source of your problem right there
Then go to Display Settings, settings, uncheck Tap-to-Click