Problem with my Logitech Z506

kashan_9

Commendable
Jun 11, 2016
3
0
1,510
0
Hello guys,

I have bought Logitech Z506. I have conected them all togather. I have conected the subwoofer to my laptop using the green cable. Now I am testing the sound. It seems that the rear spearks have muffled or ditorted and low sound. I have tried to uninstall the realtek driver and install it again but no luck. I have tried to use them without realtek driver but the same result. Moreover, I have tried to choose "as I found on internet" 5.1 surround but I this option doen't show neither here :


nor here :




Is that becuase I am not using desktop with 3 jacks for yellow and balck cables? and is there anyway to play surround sound on laptop? like buying external sound card? or this is not necessary. Lastly, should all the spearks have the same sound output or they usually different? Can I get the same output"volume and everything" from all the speakers?

Thank you so much and sorry for asking many questions
 
green cable only = STEREO 2.0 ONLY.
if you're getting surround sound.. you might have some virtual surround turned on or some other oddity. normally you would have no noise.

you need all 3 cables for 5.1
buy a usb soundcard with 5.1 support. for example a creative omni, although you have other choices.
 
green cable only = STEREO 2.0 ONLY.
if you're getting surround sound.. you might have some virtual surround turned on or some other oddity. normally you would have no noise.

you need all 3 cables for 5.1
buy a usb soundcard with 5.1 support. for example a creative omni, although you have other choices.
 

ASK THE COMMUNITY