problem with one of the channels on my kenwood amp

mikeep10

Prominent
Feb 19, 2017
1
0
510
0
hi i've recently bought an old'ish set of kenwood separates but for some reason one of the channels (the left i think) doesnt work properly, only the tweeter seems to be working or if the sub is working its very quiet! has anyone got any ideas how i can fix this or if they have had a similar problem!? i cant afford to go buy a new amp and even if i could i really like these separates! lol! thanks in advance... mikee
 

velocityg4

Distinguished
Nov 21, 2006
499
0
19,260
98
If you swap the speaker wires. Does the problem switch to the other speaker?

If the problem sticks with the same speaker.
- The cabling inside can be disconnected.
- The crossover inside may have partially failed
- The woofer may be worn out

If it sticks with the AMP. You can check inside for burst or swollen capacitors and cracked solder joints. If it has knobs. You can try cleaning the pots. Use DeOxit Contact Cleaner. Work the knobs some to work it in. Give it time to dry and wipe off excess. Use in a well ventilated area, wear rubber gloves and goggles.
 

velocityg4

Distinguished
Nov 21, 2006
499
0
19,260
98
If you swap the speaker wires. Does the problem switch to the other speaker?

If the problem sticks with the same speaker.
- The cabling inside can be disconnected.
- The crossover inside may have partially failed
- The woofer may be worn out

If it sticks with the AMP. You can check inside for burst or swollen capacitors and cracked solder joints. If it has knobs. You can try cleaning the pots. Use DeOxit Contact Cleaner. Work the knobs some to work it in. Give it time to dry and wipe off excess. Use in a well ventilated area, wear rubber gloves and goggles.
 
Thread starter Similar threads Forum Replies Date
Q Audio 1
H Audio 0
R Audio 2
J Audio 2
G Audio 0
S Audio 3
2 Audio 3
jdip13 Audio 1
IntrepidBongos Audio 0
G Audio 1
J Audio 0
196138105 Audio 2
I Audio 6
aiden_crawford Audio 1
N Audio 1
D Audio 5
B Audio 3
Carsmaniac Audio 5
R Audio 2
00maxse Audio 6

ASK THE COMMUNITY