Repairing Medion Erazer - Difficulty Disassembling

Grantymc

Honorable
Jul 20, 2013
1
0
10,510
0
I am trying to disassemble a Medion Erazer 6811 to get to the power jack as it no longer charges the battery or powers the laptop when I plug it in.

I am having some difficulty actually getting to it though, does anyone have any ideas?

I have pointed to the jack in the photo with the screw driver, I can access the rear pin which is attached to the motherboard but other than that I can't get any closer. I have tried taking the rear black plastic casing off but despite taking out all the screws the thing wont budge so I'm guessing its not meant to move.

I have tried accessing it through the keyboard way but it is not possible




edit: I managed to get at the power jack with a little brute force and patience (managed to not snap anything). The thing is soldered on solid as a rock, all the joints looks nice and clean and it doesn't budge a millimeter. Could this indicate a problem with the power brick or the DC nozzle?
 

bindiou

Honorable
Dec 11, 2013
2
0
10,510
0
on your picture the positive pin is broken at the contact point to motherboard , you can clearly see a black lline
only solution : disassemble motherboard completely, unsolder all the jack and put new one in
 


Hopefully he has figured this out in the intervening 3+ years since his last post on the subject, and hasn't just patiently been waiting for another reply, LOL. ;)

 
Thread starter Similar threads Forum Replies Date
S Laptop General Discussion 12
W Laptop General Discussion 2
R Laptop General Discussion 6
K Laptop General Discussion 4
9 Laptop General Discussion 2
J Laptop General Discussion 2
D Laptop General Discussion 1
R Laptop General Discussion 2
R Laptop General Discussion 1
Lutfij Laptop General Discussion 0
K Laptop General Discussion 1
P Laptop General Discussion 4
M Laptop General Discussion 2
J Laptop General Discussion 4
K Laptop General Discussion 1
E Laptop General Discussion 1
E Laptop General Discussion 1
C Laptop General Discussion 11
C Laptop General Discussion 1
M Laptop General Discussion 5

ASK THE COMMUNITY