ReplayTV activation hacks

Page 3 - Seeking answers? Join the Tom's Guide community: where nearly two million members share solutions and discuss the latest tech.
G

Guest

Guest
Archived from groups: alt.video.ptv.replaytv (More info?)

Let me make one more suggestion. Assuming you have less than 50 devices
that use DHCP, set the DHCP range as 2-50 (or higher if you need to).
Then set the Static address in the RTV to end in something like .88. You
don't need to set the address reservation. The RTV should connect and
use the new address although it won't show up in the "Attached Devices"
list which is only for DHCP.
Now you have the best of both worlds and, if the IP assignment truly
was your problem, it should be fixed.

From:Larry Moss
moss@airigami.com

> On 2004-10-12, Tony D <nospam@nospam.com> wrote:
>
>> There is a well known bug that allows the hw and sw to have
>> different IP addresses. Replays should be configured with static ip
>> addressses on a network that has a DHCP server. The server should be
>> set for reserved ip for the Replay and the lease time set to a week
>> or so. By doing this you insure that when a Replay reboots all parts
>> of it get the same ip address. There is a possibility you have a
>> flaky network chip, but try this first. Also do not warm boot the
>> machine after you make all these changes. Unplug for 10 minutes.
>> When the unit starts up, it may take 5-10 minutes to boot for the
>> first time.
>
> I used the Replay on this network for quite a while before this
> problem cropped up. If my current problem is related to the bug
> you're talking about, I wonder why I never ran into it before.
>
> 1. So, here's what I've done after reading the whole thread:
>
> 2. Set the router (netgear wgr614) to reserve the IP address for MAC
> address of the RTV.
>
> 3. Set the RTV to dynamic addressing (the way it was).
>
> 4. Unplugged RTV for a while.
>
> 5. Rebooted. RTV got the IP it was supposed to.
>
> As before, it worked for about 10 minutes. Then it disappears from
> the network. So, I went back and did the whole thing again, but
> changed (3) to the same static IP that the router is set to give it.
> Same thing happens. It starts up fine. 10 minutes later, it fails.
>
> The only thing I didn't do is change the lease time. It doesn't
> appear that the router will let me do that. I'm not sure what the
> length of the lease is, but that seems awfully short.
>
> I suppose another thing to try is to turn off DHCP on the router
> completely just to see what would happen. I can't keep it that way,
> but it might be worth the experiment. the problem is, I've got a 1
> year old in the house and finding time that I can do anything is
> impossible. I get to try one experiment a day, it seems.
>
> thanks again for the help.
>
> --
> Larry Moss, http://www.airigami.com
> PO Box 23523, Rochester, NY 14692, (585) 359-8695
> Airigami: The art of folding air in specially prepared latex
> containers.
 
G

Guest

Guest
Archived from groups: alt.video.ptv.replaytv (More info?)

BruceR wrote:
> Let me make one more suggestion. Assuming you have less than 50 devices
> that use DHCP, set the DHCP range as 2-50 (or higher if you need to).
> Then set the Static address in the RTV to end in something like .88. You
> don't need to set the address reservation.

Yes, you do. Upon a restart the hw may request an ip which the server
will assign which will then be different than the static one set. This
scenario almost guarantees a problem will sometimes occur.

> The RTV should connect and
> use the new address although it won't show up in the "Attached Devices"
> list which is only for DHCP.
> Now you have the best of both worlds and, if the IP assignment truly
> was your problem, it should be fixed.
>
> From:Larry Moss
> moss@airigami.com
 
G

Guest

Guest
Archived from groups: alt.video.ptv.replaytv (More info?)

In fact, the router (at least my Netgear MR814) won't allow an address
reservation to be set for a non-DHCP address. How do you do it? As long
as a static address has been defined in the RTV and that range is above
the DHCP range in the router, I've found that it works 100%. The RTV
will only request the static IP you've selected if you've set it up as
static rather than DHCP.

From:Tony D
nospam@nospam.com

> BruceR wrote:
>> Let me make one more suggestion. Assuming you have less than 50
>> devices that use DHCP, set the DHCP range as 2-50 (or higher if you
>> need to). Then set the Static address in the RTV to end in something
>> like .88. You don't need to set the address reservation.
>
> Yes, you do. Upon a restart the hw may request an ip which the server
> will assign which will then be different than the static one set. This
> scenario almost guarantees a problem will sometimes occur.
>
>> The RTV should connect and
>> use the new address although it won't show up in the "Attached
>> Devices" list which is only for DHCP.
>> Now you have the best of both worlds and, if the IP assignment truly
>> was your problem, it should be fixed.
>>
>> From:Larry Moss
>> moss@airigami.com
 
G

Guest

Guest
Archived from groups: alt.video.ptv.replaytv (More info?)

BruceR wrote:
> In fact, the router (at least my Netgear MR814) won't allow an address
> reservation to be set for a non-DHCP address. How do you do it? As long
> as a static address has been defined in the RTV and that range is above
> the DHCP range in the router, I've found that it works 100%. The RTV
> will only request the static IP you've selected if you've set it up as
> static rather than DHCP.
>
I use static in the DHCP range with a reserved ip in the router. You
seem to think there is some "theory" involved here. There is none. It is
a documented fact. The hardware and the VXWorks operating system can get
2 different ip addresses. If you use DHCP ONLY unless you have a long
lease time, you'll get different ips.
 
G

Guest

Guest
Archived from groups: alt.video.ptv.replaytv (More info?)

On Wed, 13 Oct 2004 04:43:01 GMT, Larry Moss <moss@airigami.com>
wrote:

>On 2004-10-12, Tony D <nospam@nospam.com> wrote:
>
>> There is a well known bug that allows the hw and sw to have different IP
>> addresses. Replays should be configured with static ip addressses on a
>> network that has a DHCP server. The server should be set for reserved ip
>> for the Replay and the lease time set to a week or so. By doing this you
>> insure that when a Replay reboots all parts of it get the same ip
>> address. There is a possibility you have a flaky network chip, but try
>> this first. Also do not warm boot the machine after you make all these
>> changes. Unplug for 10 minutes. When the unit starts up, it may take
>> 5-10 minutes to boot for the first time.
>

My Replays were doing that too (disapperring from the network,
although local stuff still worked) until I got that static DHCP
program.

>I used the Replay on this network for quite a while before this problem
>cropped up. If my current problem is related to the bug you're talking
>about, I wonder why I never ran into it before.
>

Maybe you thought the Replay just needed rebooting, as they sometimes
do. I've had this happening for a long time.

>1. So, here's what I've done after reading the whole thread:
>
>2. Set the router (netgear wgr614) to reserve the IP address for MAC address
>of the RTV.
>

My router won't allow that. I disabled it's DHCP server and got a
program from http://ruttkamp.gmxhome.de/dhcpsrv/dhcpsrv.htm that
allows static IP assignments. This can run on any computer on your
network (of course that computer needs a static IP).

>3. Set the RTV to dynamic addressing (the way it was).
>
>4. Unplugged RTV for a while.
>
>5. Rebooted. RTV got the IP it was supposed to.
>
>As before, it worked for about 10 minutes. Then it disappears from the
>network.

Are you sure you set your router right? Does the Replay get the IP you
set? Does your router have a DHCP table you can check? That last thing
would allow you to see is the Replay is still getting a dynamic IP
other than the one you want.

> So, I went back and did the whole thing again, but changed (3) to
>the same static IP that the router is set to give it.

Won't help if the DHCP is working correctly. It just makes it more
complicated (you always have to set the IP in 2 places).

>Same thing happens.
>It starts up fine. 10 minutes later, it fails.
>
>The only thing I didn't do is change the lease time.

The program I'm using uses a very long lease time (which is fine for
statically assigned IPs). The leases seem to be good until January
2038.

> It doesn't appear
>that the router will let me do that. I'm not sure what the length of the
>lease is, but that seems awfully short.
>
>I suppose another thing to try is to turn off DHCP on the router completely
>just to see what would happen.

It might work, but then you'd have to set static IPs on the computers
too. How about trying that program I mentioned? I've been using it
since Oct 1, and the Replays have not disappeared from the network
even once in those 12 days.

> I can't keep it that way, but it might be
>worth the experiment. the problem is, I've got a 1 year old in the house
>and finding time that I can do anything is impossible. I get to try one
>experiment a day, it seems.
>
>thanks again for the help.

--
73 days until the winter solstice celebration

Mark Lloyd
http://notstupid.laughingsquid.com
 
G

Guest

Guest
Archived from groups: alt.video.ptv.replaytv (More info?)

On Wed, 13 Oct 2004 05:05:44 GMT, "BruceR" <brNOSPAM@hawaii.com>
wrote:

>Let me make one more suggestion. Assuming you have less than 50 devices
>that use DHCP, set the DHCP range as 2-50 (or higher if you need to).
>Then set the Static address in the RTV to end in something like .88. You
>don't need to set the address reservation. The RTV should connect and
>use the new address although it won't show up in the "Attached Devices"
>list which is only for DHCP.

However, when you do that it will use the static address AND get a
dynamic one (it's buggy that way). Check your router's "Attached
Devices" list after setting a static address on the Replay.

> Now you have the best of both worlds and, if the IP assignment truly
>was your problem, it should be fixed.
>
>From:Larry Moss
>moss@airigami.com
>
>> On 2004-10-12, Tony D <nospam@nospam.com> wrote:
>>
>>> There is a well known bug that allows the hw and sw to have
>>> different IP addresses. Replays should be configured with static ip
>>> addressses on a network that has a DHCP server. The server should be
>>> set for reserved ip for the Replay and the lease time set to a week
>>> or so. By doing this you insure that when a Replay reboots all parts
>>> of it get the same ip address. There is a possibility you have a
>>> flaky network chip, but try this first. Also do not warm boot the
>>> machine after you make all these changes. Unplug for 10 minutes.
>>> When the unit starts up, it may take 5-10 minutes to boot for the
>>> first time.
>>
>> I used the Replay on this network for quite a while before this
>> problem cropped up. If my current problem is related to the bug
>> you're talking about, I wonder why I never ran into it before.
>>
>> 1. So, here's what I've done after reading the whole thread:
>>
>> 2. Set the router (netgear wgr614) to reserve the IP address for MAC
>> address of the RTV.
>>
>> 3. Set the RTV to dynamic addressing (the way it was).
>>
>> 4. Unplugged RTV for a while.
>>
>> 5. Rebooted. RTV got the IP it was supposed to.
>>
>> As before, it worked for about 10 minutes. Then it disappears from
>> the network. So, I went back and did the whole thing again, but
>> changed (3) to the same static IP that the router is set to give it.
>> Same thing happens. It starts up fine. 10 minutes later, it fails.
>>
>> The only thing I didn't do is change the lease time. It doesn't
>> appear that the router will let me do that. I'm not sure what the
>> length of the lease is, but that seems awfully short.
>>
>> I suppose another thing to try is to turn off DHCP on the router
>> completely just to see what would happen. I can't keep it that way,
>> but it might be worth the experiment. the problem is, I've got a 1
>> year old in the house and finding time that I can do anything is
>> impossible. I get to try one experiment a day, it seems.
>>
>> thanks again for the help.
>>
>> --
>> Larry Moss, http://www.airigami.com
>> PO Box 23523, Rochester, NY 14692, (585) 359-8695
>> Airigami: The art of folding air in specially prepared latex
>> containers.
>

--
73 days until the winter solstice celebration

Mark Lloyd
http://notstupid.laughingsquid.com
 
G

Guest

Guest
Archived from groups: alt.video.ptv.replaytv (More info?)

On Wed, 13 Oct 2004 06:37:57 -0400, Tony D <nospam@nospam.com> wrote:

>BruceR wrote:
>> Let me make one more suggestion. Assuming you have less than 50 devices
>> that use DHCP, set the DHCP range as 2-50 (or higher if you need to).
>> Then set the Static address in the RTV to end in something like .88. You
>> don't need to set the address reservation.
>
>Yes, you do. Upon a restart the hw may request an ip which the server
>will assign which will then be different than the static one set. This
>scenario almost guarantees a problem will sometimes occur.
>

Yes it does. I verified that by turning my Replays off, rebooting the
router, and then rebooting the Replays (both set for static IP). There
were still 2 entries in the DHCP table (assigned addresses). The MAC
addresses matched those on the Replays.

The static DHCP server program I found at
http://ruttkamp.gmxhome.de/dhcpsrv/dhcpsrv.htm works.

>> The RTV should connect and
>> use the new address although it won't show up in the "Attached Devices"
>> list which is only for DHCP.
>> Now you have the best of both worlds and, if the IP assignment truly
>> was your problem, it should be fixed.
>>
>> From:Larry Moss
>> moss@airigami.com

--
73 days until the winter solstice celebration

Mark Lloyd
http://notstupid.laughingsquid.com
 
G

Guest

Guest
Archived from groups: alt.video.ptv.replaytv (More info?)

On Wed, 13 Oct 2004 11:13:40 -0400, Tony D <nospam@nospam.com> wrote:

>BruceR wrote:
>> In fact, the router (at least my Netgear MR814) won't allow an address
>> reservation to be set for a non-DHCP address. How do you do it? As long
>> as a static address has been defined in the RTV and that range is above
>> the DHCP range in the router, I've found that it works 100%. The RTV
>> will only request the static IP you've selected if you've set it up as
>> static rather than DHCP.
>>
>I use static in the DHCP range with a reserved ip in the router. You
>seem to think there is some "theory" involved here. There is none. It is
>a documented fact. The hardware and the VXWorks operating system can get
>2 different ip addresses. If you use DHCP ONLY unless you have a long
>lease time, you'll get different ips.

I turned off the DHCP in my router and used the program at
http://ruttkamp.gmxhome.de/dhcpsrv/dhcpsrv.htm . It creates a list of
MAC addresses and always assigns the same IP to that MAC.

--
73 days until the winter solstice celebration

Mark Lloyd
http://notstupid.laughingsquid.com
 
G

Guest

Guest
Archived from groups: alt.video.ptv.replaytv (More info?)

Larry Moss wrote:

> The only thing I didn't do is change the lease time. It doesn't appear
> that the router will let me do that. I'm not sure what the length of the
> lease is, but that seems awfully short.

With Fixed, static or reserved IP addressing (Yet another name for it)
Lease time is meaningless... Or if you like, infinate

That IP will be reserved, or assigned to, that MAC every time for ever
or till you change it whichever comes first
 
G

Guest

Guest
Archived from groups: alt.video.ptv.replaytv (More info?)

On Wed, 13 Oct 2004 13:26:52 GMT, John in Detroit
<Blanked@sbcglobal.net> wrote:

>Larry Moss wrote:
>
>> The only thing I didn't do is change the lease time. It doesn't appear
>> that the router will let me do that. I'm not sure what the length of the
>> lease is, but that seems awfully short.
>
>With Fixed, static or reserved IP addressing (Yet another name for it)
>Lease time is meaningless... Or if you like, infinate
>
>That IP will be reserved, or assigned to, that MAC every time for ever
>or till you change it whichever comes first

Mine (with that program I'm talking about, at
http://ruttkamp.gmxhome.de/dhcpsrv/dhcpsrv.htm) say they last until
2038. I probably won't have any of the same devices then, but it would
renew to the same IPs.

--
73 days until the winter solstice celebration

Mark Lloyd
http://notstupid.laughingsquid.com