s-color x3000 teblet stuck on logo how to refix?

Try starting it up in "Safe Mode" and see if it will fully load. If it does the access will be restricted, but you will also then know that there is either a bad app, virus or malware on the tablet that will need to be removed to resolve the problem.

Should it not load in "Safe Mode", or removing whatever is causing the issue not resolve the problem. You may then have to do a "Hard Reset". However, I would save that for a last resort, as it will wipe all your personal data.

To get into "Safe Mode" please do the following.

1. First turn off the tablet.

2. Next press and hold "Power" until you see the manufacturers logo on the screen, then release the power button.

3. "Quickly" press "Volume Down" and hold it for few seconds until you see the message "Safe mode: ON" or something similar.

4. If you wanted disable it, simply repeat the steps above, and you should see "Safe Mode: OFF" rather than on.
 
Try starting it up in "Safe Mode" and see if it will fully load. If it does the access will be restricted, but you will also then know that there is either a bad app, virus or malware on the tablet that will need to be removed to resolve the problem.

Should it not load in "Safe Mode", or removing whatever is causing the issue not resolve the problem. You may then have to do a "Hard Reset". However, I would save that for a last resort, as it will wipe all your personal data.

To get into "Safe Mode" please do the following.

1. First turn off the tablet.

2. Next press and hold "Power" until you see the manufacturers logo on the screen, then release the power button.

3. "Quickly" press "Volume Down" and hold it for few seconds until you see the message "Safe mode: ON" or something similar.

4. If you wanted disable it, simply repeat the steps above, and you should see "Safe Mode: OFF" rather than on.
 

ASK THE COMMUNITY

TRENDING THREADS