S7 edge android system battery drain

Status
Not open for further replies.
Jun 21, 2018
3
0
20
1
On my at&t s7 edge recently updated to oreo my SOT is only 2 hours and android system is causing massive battery drain any suggestions?
 
That sounds rather odd for the OS itself to be the cause. Try running it in "Safe Mode" for a while and see if that changes. Yes, you will have limited access to things in "Safe Mode", however if it has a charge that lasts longer while in that mode, then you know it isn't the OS that is the issue, but something else that is on the device. Which you would need to remove to resolve the issue.

If it still does it in "Safe Mode", then while it could be the OS change, it could also just be the battery is in need of replacing. First try reverting back to the prior OS version. Just be sure you back up your personal stuff off the device before doing so. Then see if it still drains fast. If it does, it is the battery.

To get into "Safe Mode" please do the following.

1. First turn off the phone.

2. Next press and hold "Power" until you see the manufacturers logo on the screen, then release the power button.

3. "Quickly" press "Volume Down" and hold it for few seconds until you see the message "Safe mode: ON" or something similar.

4. If you wanted disable it, simply repeat the steps above, and you should see "Safe Mode: OFF" rather than on.
 
Jun 21, 2018
3
0
20
1
GUYS I FOUND THE SOLUTION!

So i sum up all the problems regarding android system battery drain in s7 edge and after applying this settings i got my battery running normal again.solutions are as follows

1. Clear data from google services
2. Force stop chrome , facebook
3. Smart alert off
4. In oreo restrict background usage of android system
5. Check that your cell signal are not low
6. Wifi always turn on select never
7. Google backup off

I applied all those settings and in upcomming time i will check what was the give culprit

 
Sep 4, 2018
1
0
10
0


How did you do #4? (In Oreo, restrict background usage of android system)
 
Oct 17, 2018
1
0
10
0


You go into the app settings and click the ... and go to show system apps. Then scroll down to Android System, and then down to Background usage.

It's night and day when you restrict it, everything is so much faster and my phone can actually wirelessly charge again.
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
S Android Smartphones 1
D Android Smartphones 4
C Android Smartphones 1
A Android Smartphones 1
PhilipMichaels Android Smartphones 2
M Android Smartphones 1
F Android Smartphones 7
T Android Smartphones 1
T Android Smartphones 1
a cooperator Android Smartphones 9
S Android Smartphones 1
L Android Smartphones 1
M Android Smartphones 1
M Android Smartphones 1
R Android Smartphones 1
K Android Smartphones 4
G Android Smartphones 0
J Android Smartphones 3
J Android Smartphones 1
I Android Smartphones 1

Similar threads


ASK THE COMMUNITY