Samsung WB100 issue?

cyrax037

Honorable
Dec 17, 2013
2
0
10,520
1
Hi, a friend of mine gave me her camera to take alook at cuz it was messing up.

Is was working fine, the next time she went to use it, it poped up an error message saying "remove lens cap" and beeps 3 times, yet no lens cap is on obviously.

When you turn it on, the lens will extend out all the way to full zoom then will retract back when the error comes up, but it will not fully retract back in the way its suppose to.

I was able to push it gently back in slightly more then it as before, but it wont go any further. Obviously it wont do anything when that error is on. I can get to the settings when I turn the dial to the settings but thats about it.

I'm not sure how long she's had it, so idk if its still under warranty or not. But I've heard Samsung is very poor in the customer service department and is very picky about honoring warranties.

I did a google search for the specific issue, but nothing came up with any merit. I wanted to ask around to see if there might be a way of fixing it. Telling her that her camera is shot is not something I look forward to so if there is a way to get it workin again, I'd really like to try!
 

kenrivers

Splendid
Moderator
One possibility is that there is particle of dirt or something around the lens barrel. If possible you could try gently cleaning around the barrel of the lens to remove anything that may be blocking it from retracting. I have heard that some people have solved the issue by gently tapping the end of the lens barrel against a solid (hard) surface. Before trying anything I would make sure the camera is out of warranty.
 

cyrax037

Honorable
Dec 17, 2013
2
0
10,520
1
Thanks for the tip. I actually was able to get it fixed without any thing complicated. I took it to someone who use to work in radioshack YEARS ago back when they actually knew about electronics repair (this person being my dad) and he used an old trick the old timer that he worked for taught him. He repeatedly pushed the power button. This cleared out the glitch in the sensors and now it works just fine!

SO, if anyone comes across this, and has a similar issue, try pushing the power button repeatedly for a couple seconds, then press it normally to turn it on. Doesn't always work, but that should be something to try before anything else. Sometimes the simplest solution is the best one.
 

Steven373

Estimable
Mar 7, 2014
1
0
4,510
0
Hi had this problem with my WB100. Zoom would come out then pop back in and say zoom nit not operate normally, please put new batteries in and try again or contact bla bla. What i did when the zoom popped out is i held onto it and didnt let it retract back and turned it back on. It worked after that so i guess the zoom must of been a little forced in when it was in use last in when turned on it wasnt fully going forward. Worked for me so worth a shot
 

55zel

Commendable
Aug 19, 2016
1
0
1,510
0
Fixed my son's WB100 with this lens cap error code by holding down the shutter button whilst turning the camera on. Fixed straight away and works fine now. Hope this helps anyone else with the same issue.
 
Thread starter Similar threads Forum Replies Date
M Digital Cameras 0
G Digital Cameras 0
A Digital Cameras 1
K Digital Cameras 2
S Digital Cameras 4
B Digital Cameras 1
M Digital Cameras 2
T Digital Cameras 1
J Digital Cameras 1
G Digital Cameras 0
J Digital Cameras 1
M Digital Cameras 0
H Digital Cameras 1
M Digital Cameras 0
M Digital Cameras 0
G Digital Cameras 0
G Digital Cameras 0
W Digital Cameras 1
A Digital Cameras 1
N Digital Cameras 1

Similar threads


ASK THE COMMUNITY

TRENDING THREADS