Sony Vaio (svs13a290x) Replacement Battery Problem

Apr 4, 2018
1
0
10
0
Hello, my Sony Vaio battery is getting weaker so I got a replacement for it on ebay. It is advertised as OEM and appears to be the real deal - it has the Sony name and shows the same specs listed on it.

I can't get it to charge, though, and it is giving off some strange symptoms. When I first replaced the battery, I could power it on without the charger and it had a 59% charge. When I plugged it in, the battery icon has the message of "plugged in charging" but the 59% never went up. When I unplugged it, the system shut down and would not power on unless it was plugged in. I removed the battery and re-inserted it, and it powered on again without the charger, this time with a slightly lower charge.

I have tried some of the basic troubleshooting, like uninstalling the battery driver and resetting the battery with the pin hole in the bottom of the laptop, but it has not worked. I have left it charging overnight. I have tried two different chargers. I have even told the seller of my problem and received a second battery, with the same results.

My original battery does not give any of these symptoms. Even though the charge it holds is not great, it still charges and still works normal with both chargers.

Any thoughts or suggestions are appreciated.

 
Thread starter Similar threads Forum Replies Date
J Laptop Tech Support 1
bjsmasth Laptop Tech Support 0
M Laptop Tech Support 1
B Laptop Tech Support 0
I Laptop Tech Support 0
M Laptop Tech Support 1
P Laptop Tech Support 0
J Laptop Tech Support 1
D Laptop Tech Support 0
Zaell Laptop Tech Support 3
L Laptop Tech Support 0
M Laptop Tech Support 3
M Laptop Tech Support 1
A Laptop Tech Support 0
D Laptop Tech Support 0
N Laptop Tech Support 0
S Laptop Tech Support 3
S Laptop Tech Support 1
melihiseri Laptop Tech Support 1
T Laptop Tech Support 1

ASK THE COMMUNITY