Subwoofer and center speaker not working

melissacorynn

Commendable
Jul 10, 2016
1
0
1,510
0
On my home theater system, which was working two days ago, I can't hear voices, only background music/sounds. I have checked the sound settings and all seems to be correct for surround speakers. I did s speaker check and it seems that my subwoofer and my center speaker are not functional. I have rechecked that the wires are in securely. I have switched the poles back and forth multiple times. I even put a new set of wires in my center speaker as i have a few extra. Any ideas as to why I still can't hear the voices? Thank you
 
Connect the center channel speaker to one of the working channels. If you get sound the problem is in the main unit. If this is a home theater in a box system which usually has a passive subwoofer then two of the amp channels in the main unit have a problem. Hope it's under warranty as it's usually more money to repair than it's worth.
 
Connect the center channel speaker to one of the working channels. If you get sound the problem is in the main unit. If this is a home theater in a box system which usually has a passive subwoofer then two of the amp channels in the main unit have a problem. Hope it's under warranty as it's usually more money to repair than it's worth.
 
Thread starter Similar threads Forum Replies Date
picasounds Audio 5
bridgestone-tired Audio 3
W Audio 8
J Audio 1
Exotic_Nefariousness Audio 1
Al319 Audio 10
KARTHIK385358 Audio 2
T Audio 2
N Audio 1
B Audio 5
K Audio 4
S Audio 3
libertythegamer Audio 2
P Audio 2
B Audio 13
A Audio 6
S Audio 3
Belkon Audio 2
Belkon Audio 1
G Audio 1

ASK THE COMMUNITY