Sudden crash during OS installation on ThinkPad X31


Jan 27, 2010
This one has me completely stumped.

I just bought myself a good used IBM ThinkPad X31 (it's a 2672-CBU, if you'd care to look at original specs). I swapped the original 40GB HDD out with my WD 320GB unit, and I've been attempting to install a dual-boot Ubuntu/Win7 system. I've done such installs countless times before, and I've never run into this problem.

The problem: No matter which OS I attempt to install, the notebook shuts down suddenly during the installation process. The sudden shutdown occurs without warning, and at precisely the same point in the installation process (near the very end, in both OS'es). All at once, the screen goes dark, the HDD makes a single "click" sound, and the system is dead.

Here is what I've tried (in vain) in an attempt to troubleshoot:

~Changed the RAM out using various types and configurations (everything from the stock 256MB PC2100 to 1.5GB PC2700). All DIMMs are known to be functional.

~Attempted installs on both the 40GB HDD and the 320GB HDD. Both drives are fully functional in other laptops, and both have passed extensive disk diagnostic tests.

~Removed the battery and tried to install on AC power.

~Removed the AC power and tried to install on battery power.

It should be noted that, as this system does not contain an internal optical drive, I have attempted installs using a pair of 4GB USB drives (one containing Ubuntu, the other containing Win7). Both drives function properly in other systems and have been used successfully in the recent past for OS installation on other systems.

It should also be noted that the machine seems to be able to run indefinitely using the Ubuntu USB drive as a "live CD" type environment. I have run the system this way for hours on end, and it never crashes until I try to actually install.

I can't imagine what could be causing this problem, and I really wish I could figure it out. I don't know what else to try.



Well, if it is crashing with both linux and w7 installs, it most likely isn't a corrupt install file(s). I'm betting that there is an issue with the USB controllers not being able to handle the install. If you can somehow refresh the chipset prior to an install, it will reset the USB controllers and perhaps allow you to do an install.

Otherwise than that, you can look into an external CD/DVD rom and see if it will allow an install of either via CD/DVD.
Thread starter Similar threads Forum Replies Date
Amir110hkr Laptop Tech Support 0
N Laptop Tech Support 3
T Laptop Tech Support 1
N Laptop Tech Support 1
M Laptop Tech Support 6
Semilore kaj Laptop Tech Support 0
P Laptop Tech Support 1
abdulsalamalvi Laptop Tech Support 1
C Laptop Tech Support 9
scyron Laptop Tech Support 2
RodrigoTTD Laptop Tech Support 1
J Laptop Tech Support 2
R Laptop Tech Support 3
A Laptop Tech Support 1
K Laptop Tech Support 3
A Laptop Tech Support 15
K Laptop Tech Support 1
E Laptop Tech Support 1
D Laptop Tech Support 2
N Laptop Tech Support 4