toshiba c55d wont start i replaced everyting

May 17, 2018
2
0
10
0
I have a Toshiba satellite c55d-b5102 laptop that I cant get to power on. At first I thought it was the ram , so I replaced the ram , even with the specified replacement. ( I replaced the ram, because at that point It would power up , with the power button ring illuminated, fan and optical drive activity... but no screen.) I tried connecting to an external monitor , both hdmi and vga. Nothing , so I replaced the ram. no change. So I replaced the motherboard. Now I wasn't getting anything besides the power to unit light on the front to illuminate , but wouldn't do anything when power button depressed. Also, the power to unit light is orange with battery in and white when removed. I next replaced the power button card, because sometimes with it opened and occasionally the led on the card would light when pushed by finger not thru the power button on palm guard. Okay, so the replacement power button arrived today and it had no effect. So heres where Im at … ive checked with a multimeter the charger, power inlet, and tried removing anything connected to the motherboard for possible short. PLEASE , tell me what im missing ?? the motherboard is new , the power switch is new , the hard drive is new , the ram is new,,.. im not taking this to a computer repair, to spend 80 bucks to find out something after coming this far.. So, at this moment the laptop has an orange led on the front with charger connected and white if I remove the battery . Depressing the power button does nothing, no fan , no lights , no bios.. nothing. The charger works and im getting power to the motherboard. Thank you for any advice you can share in advance :)
 
I do think the old board has a problem (with video especially) however I suggested this as to test if the new board is faulty. Sounds like it is. Now you can get the seller to replace it for you and then you can truly see if that resolves the problem.
 
May 17, 2018
2
0
10
0
Okay , so I put the old motherboard back in. It does now power on (light ring around button, and I can pop the optical and it's reading a disk).. but nothing else . No screen , no bios, only the single light in front , now white with a charged battery . I don't hear the fan though . How can I test the fan
 
I do think the old board has a problem (with video especially) however I suggested this as to test if the new board is faulty. Sounds like it is. Now you can get the seller to replace it for you and then you can truly see if that resolves the problem.
 
Thread starter Similar threads Forum Replies Date
B Laptop Tech Support 8
justin0106 Laptop Tech Support 7
B Laptop Tech Support 1
J Laptop Tech Support 1
H Laptop Tech Support 3
G Laptop Tech Support 1
S Laptop Tech Support 1
M Laptop Tech Support 1
T Laptop Tech Support 1
U Laptop Tech Support 2
S Laptop Tech Support 3
J Laptop Tech Support 2
L Laptop Tech Support 1
H Laptop Tech Support 1
H Laptop Tech Support 1
P Laptop Tech Support 1
Z Laptop Tech Support 1
H Laptop Tech Support 1
R Laptop Tech Support 1
G Laptop Tech Support 3

ASK THE COMMUNITY