Question Unity games using MOSTLY integrated GPU

Apr 18, 2019
6
0
10
0
Hello everyone! It's my first post here and it's because I need help :)

Before stating my problem I want to say that yes, I double checked if my nvidia control panel had my dedicated GPU selected for the games I tested. As well as maximum performance on power settings there. I also tried running games with administrator, disabled full-screen optimization in compability settings and tried making them compatible with windows 8 in same settings screen (for no reason. Didn't work too tho). And it didn't happen before. It started happening like couple months ago and I don't even know what changed then to bring this problem into daylight!

THE PROBLEM:
When I run unity game my computer uses integrated video card. It uses dedicated too, but like 5% of it or so. How do I know this? I launch the game, get 20 fps. I change resolution, video settings and etc. Still same 20fps. In both menu and in-game. Then I lower game and open task manager. And my dedicated GPU usage rises drastically. The moment I lower my game. When I maximise my game it drops down again. And when I maximise the game the fps is 200-400 or above and it immediatelly drops back to 20-ish.
I first noticed this problem in game 7 days to die. Main menu was 20 fps (as well as the game itself) while a year ago or so when I played it main menu fps was 900+ fps. Tried a lot of stuff to make it better with no help. Then thought maybe its not the games problem, but my other games (League of Legends, Terraria, Counter strike: Global offensive etc.) were running just fine. So I tried other games that also run on the same engine (unity). I tried overcooked 2, oxygen is not included. And the same thing happened! I was trying stuff for weeks. Every day I open the game, try some stuff to fix it. Then get frustrated. Close everything and do something else. Repeat that another day. And then one day the most illogical solution kinda worked - it was pressing f something key to exit fullscreen mode and pressing again to enter it again. For some reason fps then rose to playable level and I forgot about the problem because I was tired of it.
Now I was sitting and I remembered how I used to play Russian fishing 4. I thought I will download it again! So I did just that and it was unplayable. Had 20fps from the time I launch the game and cutscenes happen to the game itself. Same with my native 3840x2160 resolution. Same with 1600x900 resolution. I was surprised. Then I realised it.. I checked the game engine it's using.. And guess what, it's unity!!! I tried going to settings and exiting the fullscreen mode (which put me in 200-300 fps) then turning fullscreen on again (it pops back to 20fps). And there is no button to turn fullscreen on/off so that solution is not working here..

There are 3 very confusing things that bother me:
  1. Other games that run not on unity engine works fine.
  2. These games (7dtd, russian fishing 4) used to work fine a year ago or so. On this same laptop. I didn't do any hardware changes. I didn't reinstall windows or did any drastical software changes like that either.. I think
  3. The GPU usage is good when game is minimised and is bad when it's maximized. How in the hell did this happen :D This should be all the way around!
So does anyone have any ideas what can be wrong here? I mean any ideas. Even the dumbest ones.. I had suggestions to turn my integrated video card off completely, but I heard that it is not healthy for my PC so I decided not to try that.

MY LAPTOP SPECS:

I have link to my dxdiag specs that I got to post in the 7 days to die forums a while back (I don't know if I can add link to that forum post tho? Is it not against the rules to post links to other forums?): https://pastebin.com/0Er1GksY

It's Lenovo Y50-70 laptop
Processor: intel Core I7-4720HQ 2.60GHz (8CPUs)
Integrated GPU: Intel HD graphics 4600 (I believe it has 4GB VRAM)
Dedicated GPU: Nvidia GeForce GTX 960M
RAM : 8GB
DirectX: 12
I'm using plugged in keyboard (my laptops ctrl key broke, so I'm using USB keyboard now) and corsair mouse. And my PC is always plugged in to charge.
 
It can take a while for people to answer if they don't have an 'instant' answer to the problem. Unless it is something severe (the laptop is billowing smoke, etc.) patience is warranted and appreciated by all on the site.

Yes the post is long, but that wouldn't be a factor in if anyone answers it. Only having suggestions would.

I noted you didn't mention the temps for the laptop during all this (and in all the info given), so what are the temps that the device is registering during normal use (non-game) and when you are gaming? This info would be important in helping to determine the issue.

Also, you state that 'you' didn't make any changes to the laptop, however, any installed application/programs, any updates to already installed programs and any system updates could easily cause issues. So, on top of the temps, what updates, installs, etc., made changes to the laptop just before the problem started? If it was any of these installs/updates, etc., that are the cause, you may need to do a system restore to a restore point prior to the problem starting.

However, I would start with the temps. Check/monitor them and then get back to us with the info.
 
Apr 18, 2019
6
0
10
0
Oh, okay, thank you for your answer!
I have never monitored my pc temperatures, so I downloaded HWMonitor and tested it out. Tried it with idle PC and then ran russian fishing 4 (game I'm having this problem in). Played there for couple minutes with low fps just so temperatures would be more accurate :)

Idle temperatures:
Lenovo Y50-70 - 56°C
CPU - 55°C
Nvidia GPU - 46°C
Intel GPU - 50°C
HDD - 36°C

In-game temperatures:
Lenovo Y50-70 - 73°C
CPU - 73°C
Nvidia GPU - 64°C
Intel GPU - 65°C
HDD - 38°C

And I know that updates or app instalations can make this happen. I meant that I didn't made any hardware changes (physically changing parts inside or something like that). And I'm not sure when it started, because when I played these games a long time ago they worked fine. Then I stopped playing them for a while (more then couple months, maybe close to a year) and now this issue is here. The games I played during that break were not using unity engine (I still play them now from time to time) so they were and are working fine..

I guess CPU temperature is kinda high? It's above 70 (I think only core#0 was above 70°C). And Nvidia dedicated GPU is heating too, so it's kinda being used. I know it's being used normally when I minimize a game tho. In the HWMonitor app there were more information that I didn't understand so if I need to check it out and monitor it too let me know :)
 
No the temps seem quite normal, so that would not be the issue.

However, playing with low FPS wouldn't make the temps more accurate. You need a view of what they are at when you play as you normally would.

Also, you said you haven't played in a while, then it is possible that something else on the system is using the resources and causing your issues. I would suggest you try making sure nothing is running, even in the background, that would not have been before.

IMPORTANT NOTE: The location I am referring to (below) can cause lots of issues if you mess with the wrong thing, so please be careful. Do not change any of the settings in the section I am suggesting you check, without first making sure that it is something you can indeed turn off/suspend. Additionally, do not change anything on the other tabs.

Go to "Start" and in the search box type "msconfig" (without the quotes). Click on it in the list that shows (it should be the only thing listed) and then go to the "Startup" tab. Check what items are starting automatically when Windows starts. If there is anything that could be dragging down resources, like say antivirus, etc., and uncheck the box next to them to turn off their ability to start when the computer starts. Again, do not turn off anything that would be 'needed' and if you are unsure of any item, look it up online before unchecking it.

Once the changes are made, then reboot the computer and see if this resolves your issue.

Just remember to check the temps when playing as you normally would FIRST before doing the above.
 
Apr 18, 2019
6
0
10
0
Just tried the game that runs fine (it's not using unity engine) and looked at the temps while playing it. It was pretty similar to previous ones:
In-game temperatures:
Lenovo Y50-70 - 71°C
CPU - 70°C
Nvidia GPU - 59°C
Intel GPU - 63°C
HDD - 41°C

The startup tab in msconfig directs me to task manager startup tab. I have all the things that are not needed for me turned off (to speed up my boot time). And I have tried to disable almost everything in there before too with no help :(
 
Apr 18, 2019
6
0
10
0
Ammm.. I already said that I tested a game I'm having problem with. I said that I played it with low fps because that's exactly the problem I have - low fps, using integrated GPU. If I could get high fps (normal playable framerate) I wouldn't try to solve it because I would not notice any problems I think :D
 
I understand and read what you said, however your original post said you played it as normally but got low fps. Rather than intentionally choosing that. Now if you are getting that same amount and the same temps no matter which you try, then that is different and would say the temps are not being effected.

I am at a bit of a loss, as you state above that those not running in unity engine are running fine, but those with it aren't. With the temps not being a problem, and if you already updated the drivers, or even downgraded the drivers, then the problem would seem to come through unity engine.


Anyone else have any suggestions?
 
Apr 18, 2019
6
0
10
0
So far I tried deleting visual C++ restributional (2017) packages (both x64 and x84) and downloaded 2015 ones, didn't help. Then downloaded 2017 ones again. I also wrote to unity forums, maybe there will be someone who knows what can be wrong here.. And the problem is still here for now
 
Thread starter Similar threads Forum Replies Date
S Laptop Tech Support 11
W Laptop Tech Support 1
Marshall Honorof Laptop Tech Support 0
Marshall Honorof Laptop Tech Support 0
K Laptop Tech Support 3
M Laptop Tech Support 4
J Laptop Tech Support 2
M Laptop Tech Support 1
L Laptop Tech Support 3
A Laptop Tech Support 5
E Laptop Tech Support 1
S Laptop Tech Support 1
M Laptop Tech Support 1
S Laptop Tech Support 3
AndroKrazy Laptop Tech Support 4
S Laptop Tech Support 7
N Laptop Tech Support 12
B Laptop Tech Support 1
S Laptop Tech Support 3
S Laptop Tech Support 7

Similar threads


ASK THE COMMUNITY