USB Headset Audio Detection Problem

Youssof

Prominent
Feb 15, 2017
1
0
510
0
Hello! I have a problem with my new headset which I recently bought and I'm hoping to find an answer here.

I used to have a Logitech G230 which has 2 plugs (one for the sound and one for the mic obivously). When I plugged it in, the Realtek HD Audio Manager would pop up and detect that I have plugged in something new and asks me what it is. This was working perfectly fine with no troubles at all until I damaged my headset. So I decided to buy a new one!

This is how my playback devices tab looks with my Logitech Headset
http://imgur.com/a/kMixE

I have a SteelSeries Siberia 150 headset with a USB plug now and it's causing me some trouble when opening some programs (e.g steam). When I plug my new headset in, Realtek does not pick up that a new device is connected in the front. It only sees my monitor's built in headset in the rear. And because of this it creates 2 separate devices in the playback devices tab.

This is how my playback devices tab looks with my SteelSeries Headset
http://imgur.com/a/IrKmu

Now, every time I open something like Steam, my computer keeps switching between both "Speakers" and "Headphones" for a good minute and eventually stops on my Headphones, going back to normal again. But every time I open a game, it does the same thing for another good minute or so, and then randomly does it while I'm playing the game. I want it so my "Headphones" and "Speakers" are joined in one just like with my Logitech Headset so that this problem doesn't happen, or if there is somehow to stop this from happening.

Here's what I tried so far:

I tried disabling "Speakers". It just mutes my sound then brings it back for a good minute. I'm assuming it's not detecting an audio device to switch back and forth to so it just mutes it completely instead of switching.

I tried uninstalling Realtek High definition Audio from device manager. It does the same thing as disabling the "Speakers" as I did in step one, but then it re-installs Realtek and my original problem is back.

I tried uninstalling the Engine for Steelseries and re-installing it. Still nothing.

I tried uninstalling my headset itself from my computer and then restarting my PC for it to reinstall the headset. Still nothing.

I tried plugging my SteelSeries Headset in different sockets. Still nothing.

Should I look into getting another headset with 2 plugs or is there someway to fix this?

Thanks for reading. Any help is greatly appreciated.
 

popatim

Splendid
Moderator
You're going to need to take those back if you can and get a headset that uses 3.5mm jacks like theold one had.
USB headsets have their own built in soundcard and don't use your onboard realtek so you lose smooth transitions with headset to speakers because they are on different audio devices.
 
Thread starter Similar threads Forum Replies Date
Alh9991 Audio 0
T Audio 0
brixsat Audio 2
pbeans Audio 0
Zyngot Audio 0
Wendyful Audio 1
D Audio 1
swat14888 Audio 2
Vexzionel Audio 3
Kartunz Audio 6
T Audio 1
S Audio 1
E Audio 2
F Audio 0
B Audio 0
T Audio 0
Captain Kino Audio 0
S Audio 3
W Audio 3
U Audio 3

ASK THE COMMUNITY