USB Ports Going Off and On

electrosurge

Honorable
Jun 10, 2012
4
0
10,510
Hey guys, over a month ago I got a Sager NP8250-S running windows 8 and it has been working great. The laptop has 2 USB 2.0 connections on the left and 1 USB 3.0 on the right. But for the past week the the two USB 2.0s have been making any device that is plugged in blink off and on. At first I figured it was a hardware issue such as a loose connection or some defective part. But today I tried using my USB hub on the ports that were not working and after installing some drivers for the hub they work great. But as soon as I try any other device they blink off and on. Any advice on a fix would be much appreciated. Thanks!
 
Solution


If that don't work, make sure you're not over the power specs for USB devices, some devices like Ipads draw too much if the port are "standard" and the computer shutdown the ports...

PS: Plugin more than 1 device per USB slot can also make this happen

gbryan101

Honorable
May 28, 2013
15
0
10,590
It could be a selective suspend issue. Open your power options menu from the control panel, and then select the option to change plan settings for the plan you are using. Open the advanced options menu and disable "Selective suspend" from the USB tab in the drop down.
If this doesn't work, there are other things to try.
 

spawnkiller

Honorable
Jan 23, 2013
29
0
10,610


If that don't work, make sure you're not over the power specs for USB devices, some devices like Ipads draw too much if the port are "standard" and the computer shutdown the ports...

PS: Plugin more than 1 device per USB slot can also make this happen
 
Solution

gbryan101

Honorable
May 28, 2013
15
0
10,590


+1

Some high power devices (in my case, a Razer USB headset and a mechanical keyboard) draw too much power and only one will work at a time.
 

electrosurge

Honorable
Jun 10, 2012
4
0
10,510


Unfortunately it did not work
 

gbryan101

Honorable
May 28, 2013
15
0
10,590


Go to Sager's site and make sure you have the most up to date drivers for your USB controllers. Next, go into BIOS and see what the settings are for your USB controllers. If there is some power saver or such enabled, disable it.