Wi-Fi slow only on laptop, and only on one network

Apr 1, 2018
2
0
10
0
Hi,

I have an Acer Spin 3 running Windows 10 that I bought while at school, and on the school Wi-Fi (eduroam) I get great speeds, but whenever I come home, my speeds slow to a crawl on my home network. I've used fast.com and speedtest.net, and both tell me I'm getting anywhere from 800kbps to 2.0Mbps, whereas using the same websites on my phone using the same Wi-Fi network, I get speeds of 50-60Mbps. No other devices in the house have any difficulty with the network.

Our router is an Actiontec MI424WR from Verizon.
 
Try this....

1. Go to "Control Panel".

2. Next go to "Network and Internet" and then "Network and Sharing".

3. Now click on "Manage Wireless Networks".

4. On this screen, remove all wireless connections by "right clicking" on it and select "Remove network" from the drop down menu.

5. After doing this, close the open windows and reboot the computer.

6. Once the computer is fully reloaded, scan for the "WiFi networks".

7. Click on the available network that you want to access and select "connect".

8. It takes a moment, but then you will be asked to give a password for your WiFi connection. Type in the password and click the "connect" button.

It should now be connected.

NOTE: If this doesn't work, you may want to reset your modem/router, and then once it is fully loaded again, repeat the above steps.

If this doesn't work, test seeing if your laptop will connect via Ethernet. If so, then your WiFi card may be going. You can either look to replace it/have it replaced, or get an external (plugs in via USB) WiFi card.


Another way to try it is to...

1. Go to "Settings".
2. Click on "Network & Security" and then click on "WiFi".
3. Now click "Manage known networks".
4. Select the WiFi connection you want to remove.
5. Click the "Forget" button.
6. After doing this, close the open windows and reboot the computer.
7. Once the computer is fully reloaded again go to "Settings".
8. Click on "Network & Security" and then click on "WiFi".
9. Now click "Manage known networks".
10. Click "Add a new network" and enter the network name.
11. Using the drop-down menu, select the "network security type".
12. Check the "Connect automatically" option.
13. Now check the "Connect even if the network is not broadcasting" option and click "Save".

Once you have completed these steps, whenever the device is within range of that particular network, it should automatically connect to it.
 
Apr 1, 2018
2
0
10
0


Hey, thanks for the reply. I actually work in IT, so I've tried all the obvious steps like removing and readding the network and resetting the router. I've ordered a USB3-Ethernet adapter which should come in the mail tomorrow, but I'd really rather not be tethered to my bookshelf all week.

I don't think the wireless card is on its way out, since every other wireless network works just fine.
 
So it works on all other but not on the one, and removing and readding the network and updating drivers didn't work? That is extremely odd then if it is on just one.

Are you sure that particular WiFi doesn't have limitations? I know you can change the modem settings to restrict specific devices, or over a certain number of devices. Also some ISPs add limitations for how many can be using the service.
 
Thread starter Similar threads Forum Replies Date
Svlasak Laptop Tech Support 2
S Laptop Tech Support 1
ptacedom Laptop Tech Support 0
E Laptop Tech Support 1
TwackShackBoss Laptop Tech Support 0
E Laptop Tech Support 2
J Laptop Tech Support 1
AverageWhiteGirl Laptop Tech Support 1
L Laptop Tech Support 1
D Laptop Tech Support 1
T Laptop Tech Support 1
C Laptop Tech Support 2
S Laptop Tech Support 2
K Laptop Tech Support 4
D Laptop Tech Support 2
S Laptop Tech Support 1
S Laptop Tech Support 2
R Laptop Tech Support 6
S Laptop Tech Support 1
A Laptop Tech Support 3

ASK THE COMMUNITY