Wireless Mouse not working

F Red

Prominent
Apr 12, 2017
11
0
560
0
I've got this wireless mouse from Rapoo a few months ago. And 2 weeks ago it stopped working and I've still not fixed it. All of a sudden it stopped working. I suspected a bad battery. But I changed batteries several times now but all of them didn't work. I noticed the little red light does not turn on anymore. I tried to open it up but I can't seem to open it. There are a bit of corrosion on the battery terminal and it has since been there when I first got it. Pls help me :)
 

photonboy

Distinguished
Unless it's simply a synching issue (i.e. hold down button on mouse and button on the USB receiver?) anything else sounds like something is broken that you can't fix.

Don't expect to see anything you can fix even if you could crack it open (or the USB receiver).
 

Phillip Corcoran

Splendid
Moderator
You need a new mouse - - a better quality brand - - Logitech for example. Don't buy cheap.

You should have returned that mouse to the vendor if it showed signs of corrosion when it was new. That's usually a sign that the mouse has already been used previously and the batteries have been left in it too long. My guess is it wasn't a new one - you've been ripped off.
 

F Red

Prominent
Apr 12, 2017
11
0
560
0
Well that's a bummer. A friend gave it to me new. He said it already had a battery installed when he got it free with his laptop :/
 

ASK THE COMMUNITY