Won't Charge Unless Rebooted

Status
Not open for further replies.

dewdude

Distinguished
Jun 19, 2009
4
0
18,510
0
Hi,

I have an LG Stylo 3 Plus that has developed a new trick...it won't charge unless I reboot.

This started over the weekend. I got in my car to go somewhere and noticed when I plugged it up, no charging inidcator and battery was dropping from using Waze.

I assumed the charger or cable died...nope. I bought a new cable and charger...no luck.

The official LG charger and cable didn't help. I powered the phone down...removed the battery...put it back in...plugged the phone up and it immediately indicated charging and booted.

Next day...same trick. Took it off charge for a while...went to plug it up...no charge. Reboot phone....you got charge.

So I have a second battery because my first Stylo 3 got dropped...broken...and that was the end of it. So I swapped batteries.

No fix.

So...I basically have a phone that has to be rebooted if I want to plug it up. Which is a real PITA.

Any suggestions? It charges just fine after reboot.
 

dewdude

Distinguished
Jun 19, 2009
4
0
18,510
0


It will actually charge after a reboot. Let me explain it this way...

I get in my car after leaving work and plug my phone up in the usual manner and it gives no indication it's pulling power. I hold the power button, hit reboot, and after the phone powers down. The moment Android seems to issue the shutdown, it immediately picks up there's power connected. Android reboots, the phone indicates charging.

If the OS is shut down...I can plug and unplug any charger all I want and the phone has no issues telling me if it's charging or if the battery is full.

I have noticed if the USB is plugged in, then I hit reboot; it won't fast charge from the OEM adapter (or my QC compatible power pack) after it boots back up...UNLESS I actually disconnect and reconnect the power.
 
If it is doing this only when on, then I would be looking at what apps or other things are on the device causing the issue. Good virus, malware, bad app, etc., scans of the phone. You may also want to turn it off, leave it off the charger and then start it up in "Safe Mode". Once it is on, then plug it in and see if it will register the charging then. If it does, then you have something on the device that interferes with the charging. If, however, it still won't work then, you may well be in need of a new charger.
 

dewdude

Distinguished
Jun 19, 2009
4
0
18,510
0
Safe Mode resulted in the same result.

I have to rule out charger and cables. I have six different ones and an Anker USB bank. Two of my chargers are the ones that come with the phone...and one was freshly unwrapped for this.

But it sounds like if safe mode doesn't solve it....then there is some other serious issue.

This will be the last LG phone I buy. The relibility has been utterly depressing. 4 phones in 3 years...one came defective and two developed problems in three months.
 
Jul 5, 2018
1
0
10
0
I too am having the same problem...thats what led me to your post. Ugh very frustrating to have to turn ya phone off and on just to charge it. I only had this phone not even a month :(
 
Aug 1, 2018
1
0
10
0
I had the same thing happen to me. I have tried this and it seems to be working so far.
1.) Take the phone and power it off.
2.) Plug the usb cable into a computer, then power up the phone.
3.) You should get a few beeps that the phone is charging like normal when it boots up.
4.) You should see the phone charging. Also the usb symbol should be on the top of the screen.
5.) Cycle the input from usb charge to usb file transfer. Back and forth a few times.
6.) Set to charge from usb then unplug from port on phone.
7.) When you plug it back in to the usb to the phone port it should signal that it is charging.
Has been working after plugging it in and out a few time so far.
I have unplugged it for 20 min and it back in, and it seems to be working fine.
It also worked with my original LG charger and usb cable.
Hope this helps.
 
Aug 15, 2018
1
0
10
0


These steps solved the same problem for my ZTE Blade V8 Phone. It must be a bug across the android platform. Thank you!!!
 
Nov 22, 2018
1
0
10
0

Worked for me on my Huawei Mate 10 pro
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
Magafliux Android Smartphones 1
B Android Smartphones 1
D Android Smartphones 2
S Android Smartphones 1
M Android Smartphones 3
shivranjani324 Android Smartphones 1
Lil_Savage Android Smartphones 1
Krislapiux Android Smartphones 3
StrickOut Android Smartphones 4
M Android Smartphones 1
G Android Smartphones 1
J Android Smartphones 1
P Android Smartphones 3
B Android Smartphones 5
M Android Smartphones 1
S Android Smartphones 1
Y Android Smartphones 1
J Android Smartphones 1
C Android Smartphones 1
J Android Smartphones 1

ASK THE COMMUNITY

TRENDING THREADS