Xps 15 splitter problem

Jobius

Prominent
Jul 25, 2017
1
0
510
0
I have a headset that i wanna connect with my headset/mic jack in my xps 15. I already have a splitter with an in and output. As soon as i plug in all the wires i get asked what kind of device i plugged in (Maxx audio pro asks that). After i anwser headset (mic and speaker combination) it just doesnt work. I can hear some audio but the audio is really weird and jittery, and the microphone doesnt work at all.

I have seen a lot of threats where either Dell Audio or Realtek audio settings would fix the problem, but i don't have any of those programs on my computer, i only have Maxx Audio pro. (Default sound program on the XPS).

What do i do?
 
It may not be a software but hardware issue. Many computers so called 'combo' jacks don't really work well with real headsets and microphones. Your best bet is to either have a headset/mic that connects via USB or get yourself an adapter for the one you already have, that will let you use it through a USB port.
 
Thread starter Similar threads Forum Replies Date
CristianDeo Laptop Tech Support 1
J Laptop Tech Support 1
S Laptop Tech Support 6
G Laptop Tech Support 3
S Laptop Tech Support 3
V Laptop Tech Support 1
A Laptop Tech Support 3
T Laptop Tech Support 1
J Laptop Tech Support 3
A Laptop Tech Support 2
F Laptop Tech Support 1
E Laptop Tech Support 1
J Laptop Tech Support 4
P Laptop Tech Support 1
M Laptop Tech Support 2
L Laptop Tech Support 2
M Laptop Tech Support 1
A Laptop Tech Support 4
E Laptop Tech Support 6
N Laptop Tech Support 1

ASK THE COMMUNITY