1gbps internet but getting really slow speeds

Tempz66

Commendable
Oct 8, 2016
1
0
1,510
0
I've changed my ISP not long ago and I got a 1gbps internet but the problem is : I'm getting really upset by the fact that my download speeds vary from 8mbps to 20mbps ( rarely ) and the upload speeds goes around 100mbps to 500mbps, which is fine.
I'm not being able to download files fast enough and I can't even watch twitch on source quality most of the times.
I don't know much about routers / cables and things like that so if anyone can help me out, I'd appreciate it.
http://imgur.com/a/9TqQ5
I just took this pic now ( 00:10 where I am, I'm using a wired connection as well )
I updated my router / cleaned my computers and the problem still happening, I've tried turning off all of the other devices in the house and using the internet only on my computer and still the same...
 

hang-the-9

Titan
Moderator
First point of contact, once you figure out if this is an issue on one computer or on all of them, would be the ISP. Test the connection speed with the computer on the modem directly, bypass the router. The ISP will have you test that also.
 

kgt1182

Commendable
Jun 8, 2016
5
0
1,520
2
Download speed is usually slightly higher than upload speed, I suggest the following procedure as I feel that there is a network issue.
Few methods you can try.
Assuming that your computer has sufficient hardware capacity check:
1)Network adapter Speed and Duplex setting. Do you have a Gigabit Ethernet Adapter and is it at 1.0 Gbps Full Duplex? If no, set it to 1.0 Gbps full duplex, run speedtest, if problems persist go to 1.
2)Check the wires. It should be Cat 5e or better. Else go to 3.
3)Router settings: Your router should support Gigabit speeds, also check that you have the latest firmware installed, enough cooling is provided, and QoS should be disabled. If problems persist go to 4.
4) Try bipassing the router and connect your LAN ethernet cable into the modem port for the WAN. (that one cable connected to your router and modem). Run a speedtest. If its normal speed you need a better router. Else go to 5.
5)Are other people hogging your bandwidth? Multiple users streaming can tank your internet bandwidth. If no go to 6.
6)Also check that your gaming PC CPU is not overheating. An overheating CPU can throttle quite a lot. Else go to 7.
7) Call your network provider.
 

--G-V-L--

Prominent
Apr 8, 2017
1
0
510
0


Using this Ip should help you get Information on you Modem Status.
http://192.168.100.1/
Remember during bad weather.. all Modems will use Less channels because the ISP is unable to keep them open do to following reasons..
this because A- Too much interference weather related (internet cable is down somewhere in ur town/city)
B- Unstable realiablity through the Provider.(Yes even how many People are on Local SERVER ) Just like DSL but with Cable Internet As well..Yes im sorry you had to find out like this but this is the sad part of Cable as well.. the More people in ur Town/city on internet .. the slower (unstable) internet speed will get..
Example(everyone's using Comcast cable internet in ur city- Everyone getting home from work 6:30PM- internet get slower// everone's going to bed -10PM internet getting faster..and so on and so on..)
When the weather Clears up some time the service will still be slow do to power line down.. or broken cable .. yes when purchasing the modems on Amazon you will notice (how many channels up)& (Channels down).. yes this will also happen to GIGABIT internet Modems...
{Small temporary Solution}not sure it will work.. Tricking.. service cable check)) through the provider as i call it.. Cycle your modem 3 time..
unplug ur modem.. but after you plug it in.. wait for light full cycle.. {simply going to google.com} make sure
Do this 3 times.. i noticed my modem for the next 48Hours will be fast..(tricking the automated system-MSG lose cable connection... automated system will then keep ur connection healthy.. this is to monitoring ur connection stability. but then goes to normal speed afte 48Hours....
 

tmoney0985

Prominent
Nov 1, 2017
1
0
510
0
I had this same issue. Started really bad, lower speed then I had before I "upgraded." I kept working from one issue to another. Bad CSR with wrong information (another story), anyway I am using a Modem and Router combo provided by Xfinity. One thing they did was swap my 1 gbs Modem, because it seemed to be getting very hot. Changed the provisions several times and bypassed my splitter to connect direct. When the tech left we had the speed to almost half around 400-500 mbs. He came back later with another tech and connected a stand alone speed test unit up and got the 1 gbs. I double checked all hardware and it was all compatible including a cat 6e cable. Tech stated it was probably a bad network card. Checked the driver and Windows said I had the correct and current driver. I even uninstalled ALL network drivers, rebooted, let windows search and find new drivers, but none of it helped. Checked my device manager and got the exact name of my network card. Searched the web to download the latest driver and tried again. Finally, just under at 978 mbs. Only issue now is my wife and I are having issues with only our smartphones, they keep connecting and disconnecting.

Side note:
I also had to use speedtest.xfinity.com, because the standard speedtest.net would not show above 350 mbs.
 

ericlaforgeqc

Prominent
Jan 28, 2018
1
0
510
0
I got the problem too and i figured it out . It was the wire i did myself is was the order of my homemade connection .It has to be in a specific order. It's very important due to crosstalk. i had to go cut all the wires to all my connections and do it all over.
 
Mar 10, 2018
1
0
10
0


It has to be in a specific order due to crosstalk...? Can you elaborate on this? What order did you originally have and what order did you switch it to?

 
Mar 15, 2018
1
0
10
0


I also had the same Problems, have an Internet connection of 500 Mbits, but recived only 100 Mbits on my Laptop and so i tried and checked everything, but seemed nothnig really worked.
But then i found the solution:

Got to your Device-Manager ---> Networkadapter ---> search for your NIC / Network Interface Card (for example mine was a Realtek PCIe GBE Family Controller) ---> Select it an go to Properties ---> go to section Advanced ---> And now make sure:

-Look for Option "Autom. deactivate Gigabit" and set it to not avaiable!

That fixed it for me
 

jpearce8

Estimable
Sep 29, 2015
1
0
4,510
0


I looked at post - I don't see option "Autom. deactivate gigabit". What does it say exactly in that list?

Thank you.
 
Sep 14, 2018
1
0
10
0


I assume this is under:
Realtek PCIe GBE Family Controller \ Configure \ Advance tab

"Auto Disable Gigabit"

btw, "jpearce", that wouldn't happen to be Jennifer Pearce, now would it..
 

Similar threads


TRENDING THREADS