Acer aspire 4520 windows restart when shutdown

Try this and see if it helps:
Windows XP
Right click on My Computer and then click on Properties.
Click on the tab that says Advanced and then click on the Settings button under the Startup and Recovery option.
Under System Failure uncheck the box next to Automatically Restart.

Windows 7
1. Click on Start
2. Right click on Computer
3. Click on Properties
4. Click on Advanced System Settings
5. Click on the Advanced tab
6. Under Startup and Recovery click on the Settings button
7. Click to remove the check beside Automatically restart
8. Click on OK

If this does not work it may be something in the BIOS. Let me know if the above solves the problem. If it does not work we will continue to look for a solution.