Acer Aspire 5560G does not start up, black screen

acehunter99

Honorable
Jan 7, 2014
6
0
10,510
0
My Acer Aspire 5560 does not start up. When I press the power button, it lights up, and the power on led indicator turns on as well, and you can hear the CD drive running, however the screen remains black. I have taken out the internal hard drive, and the contents of it are still on it just fine. Does anyone know what symptoms it may be, and how to fix it?
 

C12Friedman

Distinguished
You can check to see if you have anything on the screen by shining a flashlight at it (with the computer powered on) you might be able to see a faint image. If you can then you have either a burnt out back light or power inverter - they are replaceable. If you're very lucky it may just be a loose cable inside.
If you do not see an image there and cannot get an image on a external monitor, then the problem would likely be your graphics. Try an external monitor first, shine a flashlight at the built in screen to see if you can see the same image faintly. If not, report back, we'll go from there
 

acehunter99

Honorable
Jan 7, 2014
6
0
10,510
0
Ok, after shining a light at it, I have noticed that the screen is cracked, and what seems to be liquid spreading. As for external monitor, there is still nothing that is being shown.
 

acehunter99

Honorable
Jan 7, 2014
6
0
10,510
0
Basically, it was working fine until I decided to turn it off, where working fine means it was running internet, applications, movies. When I attempted to turn it back on, it showed the above symptoms that I gave in the first post. As for the cracked screen, I do not know how that happened, as I have for the most part placed it on a table. Since I for the most part keep the screen closed, I suspect something may have been placed on it by relatives.
 

acehunter99

Honorable
Jan 7, 2014
6
0
10,510
0


Yeah, thats pretty much what happens. Again, I know the hard drive still works as I can access the data through use of a hard drive dock.
 

C12Friedman

Distinguished
I'll suggest attempting a reset here, with AC adapter unplugged from laptop and battery removed, press and hold power button for 30 seconds. Try starting after that.

What CPU and graphics do you have installed?
 

C12Friedman

Distinguished
I was hoping it was an APU. It would seem that your graphics is 'toast', unfortunately it is soldered onto the motherboard. To repair it you would need to look into reflowing but with a cracked screen to boot, I'm wondering about the cost effectiveness of repair.

One thing to check on (I haven't looked into this before) is if there is a way to 'blindly' disable the dedicated graphics card and just run your graphics from the APU - are you able to see anything booting into BIOS, that might run off the APU and not the dedicated card - if so, you should be able to disable the graphics in there (maybe?)
 

acehunter99

Honorable
Jan 7, 2014
6
0
10,510
0
If there was a way, I have no idea how to do it. It just won't load anything, regardless of what I try. I think I will have to just abandon it and purchase a new laptop. Thank you for your help in trying to fix it.