Acer Aspire 5738z Blank screen

Page 2 - Seeking answers? Join the Tom's Guide community: where nearly two million members share solutions and discuss the latest tech.


Jan 26, 2009
Hi all,

So here’s the story,

I have the Acer Aspire 5738z laptop now it’s been a great little laptop nothing special but has done everything i need it to do until recently.

I was casually working on my laptop one day and noticed down the bottom notification bar that my laptop battery was saying must be replaced, I didn’t think much of it at this point as all I had to do was just be plugged in because without power my battery would die in under half hour. One day I went to boot up my laptop and I couldn’t get any video signal from the laptop at all, I could see all the correct LED lights were on but still nothing on the display, also I could hear both the fan and hard drive spinning away.

I thought possibly at this stage it was just the battery, so i ordered one from eBay and replaced the battery and bam I had a post screen and thought everything was working perfectly fine and then blank screen.... people have suggested it’s the backlight or LCD panel that is broken but if that was the case I wouldn’t have got a post screen on my laptop even if it was just for a moment.

Today I tested my laptop on an external monitor and it works fine so I know the on board VGA works not a problem it’s just the main VGA on board that is causing the issue. I have done so much research online and nothing seems to solve the issue.

This is extremely interesting when I turned off my laptop removed the battery and held down the power button for 20 seconds, put battery back in booted it up and I got a very faint ACER screen. I also tried to see if maybe I accidently hit one of the display function keys which switches my display from internal to external. I got a display for 10 seconds then it went back to blank screen...

I have tried to reformat the computer no luck still no display works fine on an external. I have tried updating my bios on my laptop from 0.34 to 1.25 hoping this would fix the issue but still problem remains. Also while I was going through my Bios today I noticed the SATA controller was set to AHCI and not IDE so i tried changing that setting back to IDE however still didnt work.

I have also tried to test each individual memory slot and still nothing.. im at a loss here guys anyone got any suggestions?



Hey guys,

So great news it was the inverter. I have replaced with a new inverter and it works perfectly. very happy wish I hadnt ordered the inverter tester but at the end of the day its all fixed so issue resolved.

below ive added a screenshot with the success. :D :D :D

Thank you for everyone who has helped me troubleshoot this issue greatly appreciated!